New 2.4 MIDI Mapping feature doesn't respond to MIDI input

I feel really dumb, while I am musically just starting out but technology is my background. For the life of me I cannot get the new MIDI mapping feature to work (ironically the one I most looked forward to).

I tried in 4 different DAWs, FL Studio 20, Ableton 10, Bitwig 3, and Maschine 2. OS: Windows 8.1 x64

What I do…I right-click on the PERFORM text

Choose the “Create Common Command Mapping” menu option…

…and then I get stuck in this menu. While I can map PC text keyboard keys to the performance, this dialog does not respond at all to ANY MIDI input. I’ve tried 4 different MIDI controllers… Maschine MK3, Maschine Jam, Novation Launch Control XL, Komplete S49 keyboard controller. All of these controller work just fine playing Scaler’s musical notes, so I know MIDI is routed properly into Scaler.

What obvious step am I missing? Since nobody else has brought this up as an issue, I suspect this issue is specific to my particular setup or process.


You are not alone…

On current Win 10, I get the same null response from Studio One & Zen Beats using Atom but all fine with Maschine II Software, MPC Beats and Nano Host (using Atom)

If I look at the midi stream, my Atom is sending midi, but Scaler does not seem to see it. The QWERTY input is fine, just nothing using midi.

Will have it installed on my other systems this afternoon to test on an Arturia Keyboard and an M32.

Will post more as found

@TmacD now that you mention NanoHost, I can confirm that Scaler 2.4’s MIDI mapping feature with does work in NanoHost, just tried it with my Launch Control XL.

I made an interesting discovery, for what it’s worth…

After trying successfully with NanoHost, I opened up Maschine 2 again, since @TMacD said it worked for him in Maschine. Suddenly it worked for me too, even though prior tests failed. Ever the engineer, I immediately go “what is different this time?”. Then I get errors from LoopBE detecting a MIDI feedback loop. I go “huh??”, I don’t use LoopBE in my standard Maschine template. But Nanohost was configured to put out its MIDI to LoopBE (a virtual MIDI loopback cable). So I close both Maschine and Nanohost. Startup Maschine again by itself, and then the MIDI binding does not work anymore.

There is some sort of interplay with Nanohost that made it work in Maschine. And perhaps LoopBE played a role as well. I’m going to uninstall LoopBE to see if that makes a difference. Stay tuned…

UPDATE: yes, uninstalled LoopBE, and now Scaler 2.4 MIDI mapping doesn’t work in Maschine. Curious if @TmacD can confirm this.

I have it working! :slight_smile: A confluence of factors made it not work in any of my setups, until I figured out the pattern.

Maschine controllers automatically go into the Native (Instruments) mode when started in NI software. And I have had specific controller editor templates active when using them in Ableton and Bitwig. As soon as I took the template mapping out, and let it act as a generic MIDI controller, the MIDI CCs came through to Scaler’s new MIDI mapping feature. I suspect adjustments would have to be made by the community for the custom controller scripts for the Maschines in Bitwig & Ableton.

Also, somehow I assumed/understood that Scaler takes in any MIDI, including MIDI notes for mapping to performances. But it appears only to listen to MIDI CC messages.

I haven’t bothered with FL Studio yet, but since I have it principally working, I suspect same logic may apply there. I’ll let more heavy FL Studio users speak up if it’s an issue for them.

I had LoopBE muted and then closed it all together and Maschine w/Scaler mapped just fine in both cases.

sorry if I closed the thread prematurely, just because I got it working on my end :-o

No worries…I think I’ve got my head wrapped around the general state.

I agree it looks like the issue is related to the controllers and the respective templates. My M32 does not appear to let me map any controls to CC values (other than the hard mapped mod wheel which does trigger the Scaler midi map for one setting) I even tried Komplete Kontrol with only a little more access (2 knobs) I know the Atom is pretty hard wired into Studio One as well. I suspect as DAWs and hardware get more integrated, accessing these settings will go deeper and deeper into the system. I’ve not tried my big Arturia keyboard yet…but hopeful.

MIDI mapping the Perform panel is pretty much the exact feature I was hoping for so I’m a bit disappointed that my setup limitations constrain this. At least I have QWERTY to fall back on…maybe I’ll try a dedicated numeric input pad from 2007. :slight_smile:

Hey guys,

it was a hard thing to test due to the already existing mappings between controllers and DAWs and the user’s pre-existing mappings.

Usually, setting your controller in “MIDI Mode” works but you might lose some integrations with the host.
Programming MIDI CC directly from the DAWs (automation) can work as well for those working with the piano roll a lot.

Feel free to report any issues with details about your setup, we can address this with deeper integration with some controllers going forward.

1 Like

Thanks @Ed1. It makes perfect sense that this is tricky to implement and my use of the term “disappointed” was hyperbolic at best. This is a great release and I’m already having a blast exploring the nooks and crannies. Quick question on midi mapping…any chance we can hand prune the xml that saves session state to only toggle specific perform features? I tried some hunt & peck changes for a while today with no luck. (Nice to see Scaler laughed off my tweaks with no issues) For example, cycling through just the playback speed or the quantize settings leaving everything else unchanged would save us from creating dozens of mappings that cover a bunch of bases.

Regardless, wish I could buy the team a round to say thanks!

In Logic, you can bypass controller surfaces in the settings. Once you bypass your device you can learn which buttons or rotary controllers are assignable.
The rotary controllers are assignable to MIDI CC with the Komplete M32. With the Presonus Atom, you can assign most of the buttons.

In Presonus S1 I had no luck yet to make MIDI CC work with both the Atom and the M32.

Thanks @2KA

Been trying to access the M32 templates via the NI Control Editor but no luck yet. It does not seem to cover the M32 so I expect there is some other template editor UX. Still digging…

Limiting MIDI features might be NI’s way to manage price points, M32 being their total entry level controller. Even the $500 S49 MK1 is only mappable 50% of the buttons.

Yep…I think you are right.
I did find an article regarding using Komplete Kontrol to manage the mapping.

As I understand it, I don’t really need to map anyting speciific I just need to ensure the keyboard controls are generating CC messages and the DAW is passing those through to Scaler. We’ll see. Accessing the MIDI Assignment Editor for KOMPLETE KONTROL A-Series / M32 Keyboards – Native Instruments (

edit…that one worked for Komplete Control

1 Like