No midi nor audio output after upgrade to Scaler 2.7 or 2.7.1 on Logic Pro and Cubase


I’m running Logic Pro 10.7.4 on MAcOS 12.3.1. After u^grading to Scaler 2.7.0 I found ou that I had no sound with the scaler2 stereo au-instrument: even when playing a predefined chord sequence, or clicking on the GUI keyboard (the felt piano sound is loaded, the channel is not muted, and when replacing by another plugin I get sound).

I also figured out that I had no MIDI input either.

I tried to remove all Scaler2 VST and au-component files from my Library, and reinstalled Scaler, but no luck: still nothing working.

However, I didn’t have to register again, so I think I’ve not correctly uninstalled Scaler.

By the way, I also tried on Cubase12: and still no sound…

Any Idea on how to fix this ?

Thanks in advance,

1 Like

I have no issues with Scaler 2.7.1, Logic 10.7.5 and the latest release of Monterey 12.6.1

Check in Logic Plug-in Manager that ScalerAudio 2 and ScalerControl 2 are both
successfully validated, I have had issues with that.

Thanks for your reply,
The three plugins are correctly validated under Logic’s plugin manager.

I think I should completely uninstall and reinstall Scaler. Can anyone give me a bulletproof procedure to do this ?

Thanks in advance,

Hi @tlemeur

  • Quit all open applications
  • Install Scaler 2.7.1 (don’t worry about uninstalling)
  • Restart your Mac
  • Open a vanilla Logic Pro X file (new empty project)
  • Go to Plugin Manager and select all Scaler plugs and ‘Reset and Rescan Selection’
  • Open Scaler 2 instrument on an instrument channel

I’m feeling that will work. Failing that please ensure the internal sounds are where they are installed natively:


1 Like

I have the same issue with Scaler 2.7 and 2.7.1 with both Ableton and Reaper. Running on Windows 10. No audio coming out. No midi input. No midi sending out either when playing predefined chords.
Tried clearing cache, rescanning vsts. Tried uninstalling and reinstalling.
Reverted to Scaler 2.6 which works fine.

Hi @davide,

Thanks for your answer. Unfortunately I tried this:

  • restart the computer (not running any audio app)
  • install Scaler2.7
  • reboot
  • run Logic, close the last opened project, and create a new empty one
  • add an instrument track with Scaler2 AU instrument plugin
    ==> still no midi, and no sound

I’ve checked that my sound files are ine users/shared/pluginboutique/Scaler2/Sounds.

I’m still looking for a way to cleaning uninstall Scaler2

I tried a fresh install of Scaler2 2.4.0 and it works.
Then I upgraded to Scaler2 2.7.1 and the pb is back: no sound and no midi.

Very strange, maybe our developer @Ed1 can help you here!

Hi @tlemeur @JimJ

Could you please check what MIDI channel settings is used in the preferences panel in the side menu?

Screen Shot 2022-12-15 at 8.49.17 am

It could be that the plugin isn’t being initialized properly by the host. In your music software you can check for the audio settings and try with a different sample-rate or block-size. Changing those settings will reinitialize the plugin.



Oh yes I forgot, other users have said changing the Midi Channel to another channel and back to 1 solved the no audio output.

1 Like

Thank you. Changing the midi channel to another channel then back to 1 solved the issue for me.
Audio and Midi both work now in 2.7.1.

I confirm that changing the midi channel and setting it back to 1 fixes both the “no MIDI input” and “no audio output” issue.

Thanks for the tip.
Will there be a Scaler2 update that fixes this setup problem which is not OS nor DAW dependent ?

I had the same issue w/Live. Changing the midi channel worked for me.