Performance plays the mapped keys

Using Scaler in Bitwig, and in Performance Mode the keys that the chords are mapped to get played along with the performance. See photo for details.

Doesn’t make sense for the mapping key to play as well. I was thinking there was a setting I was missing, but couldn’t find any, so concluded it was a bug.

As you can see in the photo, the held down chord gets recorded.

Do you have Bind turned on?

Yeah I have the Settings set to Bind MIDI to Section C.

@Bernd is the resident Bitwig / Scaler expert. He has no issues with the 2 so hopefully he will chime in here. It sounds like your MIDI is bleeding over when it really shouldn’t. You didn’t tell us your set up - computer, OS, controller that might help diagnose the issue.

Mac OS 11.6.7, Bitwig 4.2.3, FL Studio 20.9.2.

Controller doesn’t matter. Even with the QWERTY controls it still pulsates the chord along with the performance. So it’s clearly something within Scaler that is the problem.

And this happens in both Bitwig and FL Studio? You are using Scaler 2.5? VST 2 or VST 3?

Happens in Bitwig and FL Studio, Scaler 2.5, VST 2 and VST 3.

Welcome to the forums @ata
Are you sure the chord isn’t part of the triggered performance? Looks like it is, which Performance are you triggering?

I was thinking that too, except for the next category (Phrases) it gives you the option to just hear the melody (or Chord+Melody) and yet you still play the chord. Also, other categories only play the melody, without the chord.

So, maybe it’s part of the performance (Performance doesn’t give you the option to hear the melody only).

Still just seems off to me, because it doesn’t sound like a performance, it sounds like a chord playing over a performance.

I haven’t gone through and tested all the different categories, because I don’t want to have to test software that I paid for.

As a suggestion, if you save the ‘State’ and post the XML, I’m sure folk here will step up to investigate and try and replicate this.

This will allow the issue to be isolated either within the Scaler midi itself (and thus o/s +DAW independent) or related to the setup. If it works ok under Windows with, say, Live, then that would point to an issue with Scaler + DAW+ o/s. Others would also be able to try it on a Mac, and there are Bitwig users who might step up.

This will only take maybe less than a minute to do, but might potentially identify the problem without your having to do testing.

If you could tell us what performance you are playing and maybe record some audio or post the State as @yorkeman suggested we could see if things are amiss or not.