Phases with Keys-lock

I am trying to force the notes of phrases to be in my selected scale. Is this possible? I have A minor selected and keys-lock enabled, but no matter if I play chords from MIDI or bind or clicking on the chord boxes, it always will play notes outside of the scale. I am assuming the keys-lock can not lock performances? If this is the case then I would like to ask this to be a feature request. But maybe I am missing something? Please help.

Hi @Jason

you can use the phrase in “Scale Mode” to trigger the pattern adapted to your selected scale.

In case you want to trigger it in chord mode but filter out of scale notes, this is not possible at the moment. We might add this in the future, we will have to discuss with the team of our options.

I have a set of chords on my Scaler track and Scaler plays them. I now want to select the keys lock function and white notes only in Scaler, then in settings I mute the chords in order to record a melody line but I can still hear other notes playing along with the melody I’m imputing.
I’m sure Scaler can do this but I can’t seem to make it happen any ideas where I’m going wrong?

It will only mute the chords if the chords are being triggered via the bind function otherwise its playing the notes form your DAW as it can’t differentiate them form your melody. Use a trigger notes to trigger the bound chord and then it will mute. See my video:

1 Like

ah… inputing… ok. so when you hit the keys you hear the notes…

Yes, when I hit the keys I also hear the notes if I don’t have the volume all the way down on my keyboard that I am playing, or if I have local=on.

I didn’t catch your setup, sorry. Hard to go on nothing. So maybe not the answer you were expecting.

I like Davide’s answer the best, but this is another possibility.

Hi Davide,

Thankyou for your prompt response.

Having seen your video I now understand that the chords will only mute via the bind function.

However when I tried this out this is what I found.

On the chord notes and the chord extensions settings everything is fine i.e. I can mute the chords and all the single notes change when the chords do, perfect as in your video.

However on the Scale notes map, Scale notes only and the Scale white notes settings, the chords don’t mute and when the chord changes non of the single notes do

so there seems to be a problem. Any ideas Davide?

Kind regards.

Reg Bower.

That’s normal behaviour as scale notes only respond to the scale you have selected and is not affected by the chords you are playing. So you could just open a new scaler, select the scale and play notes without chords if you specifically didn’t want to hear chords. Hope that helps.

That is such a good idea. Obvious but still something I’d not looked it. Thanks for your support on the forums.

1 Like