Scale Switcher not working. (v1.1)


Just watched David’s Plugin Boutique Youtube video on Scaler EQ v 1.1…He was experiencing a problem with the scale switcher…So am I !

System Specs
iMac Pro / Mojave / Logic Pro 10.5.1

Works absolutely fine on Reaper V7.03 (AU and VST3)


Hey @chrisksi Welcome to the forum and thanks for posting. Try hitting play in the DAW in Logic that seems to work. We are on it an aware there is something Logic is doing when in ‘stop’ mode. If you hit play and change then it should be working like this short I just posted. @jchdejong and devs are on it.

Hi, just tried the suggested workaround in Logic…no joy… Not a problem at the moment as I haven’t started using it on client projects yet. Can wait for bug fix. Will experiment in Reaper till then.

Devs have got it @chrisksi New installer will be up at PIB on Monday but I have DM’d you a link to it! Let me know if it works for you after install. Thanks.

Yeah key switching not working on my Mac mini M2 pro running Ventura and Logic Pro. Otherwise the new version rocks.

Hi @Laur Welcome to the forum. As per my post above we’ve got it and fixed it. New installer going up on PIB on Monday but I will DM it to you now!

Thanks I’ll let you know how it goes.

Just downloaded and installed…all fine now.