Scaler 2.5 and Reason 12

I’ve seen some posts about how Scaler isn’t working with Propellerheads Reason. I found the following works just fine for me - if I’m using Reason as a VST plugin within Reaper (the same may be true of other DAWs):

  1. Create an instrument track and load up the Reason rack plugin. Choose the instrument you want
  2. Create a new track for the Scaler plugin. Route the output from that track to the instrument track created in step 1.

I had no issue getting sound out of Reason when I did this. Previously I had tried having Scaler on the same track as the Reason rack, but no sound was played.

Hopefully this is useful to someone else using this particular setup.

Thanks and welcome to the forums @UrlFlynn I think the issue reason users were having is within Reason itself, due to lack of midi pass through. I do use it in the way you suggest though but some Reason users only use Reason itself.

1 Like

Indeed, I, like many colleagues on the forum, also use Scaler in that mode in Reaper and Ableton.
The problem certainly lies within Reason itself, which lacks midi inputs and outputs.
Normally I use drag and drop in Reason, but I am experiencing, with good results, what this video shows. The explanation is made for Instacomposer, but it works equally well with Scaler
Reason using Multi in Midi Channels (with InstaComposer but works with any VST that outputs midi) - YouTube

1 Like

Thanks for the tip about multi MIDI channels in Reason. I was already aware of loopMIDI and have it installed, but never tried configuring it to address the issue of Scaler not working in Reason. I actually was thinking about it last night and was going to try and set that up when I had some time. The video should go a long way towards resolving this issue.

BTW, I purchased Scaler and InstaComposer during the Black Friday sales on PluginBoutique and I have say they’re both outstanding, but I tend to go to Scaler quicker and more frequently for writing chord progressions.