Scaler 2.7.3 not functioning in Cakewalk or Pro Tools properly

First of all, after installing it with no error messages… there is no sound coming out in either Cakewalk or Pro Tools. I watched its audio instruments get installed onto my external samples/sounds drive successfully, but no sounds are available in the dropdown list in Scaler when I launch it. Again, with no error messages. Second, how do I configure the MIDI ins & outs of my own VST library sounds for Scaler to play back ? Since this is how I will use Scaler anyway. Also, do I use this as an effect insert or its own instrument ?

Welcome Mike4001

Ok, two question here, so I’ll respond the the first one (Scaler set up) , as that seems to be a pre-requisite of addressing the second (Scaler driving VST’s on other tracks).

I used to use Sonar (aka Cakewalk) some years ago, but switched to Live. However, I just fired it up and added Scaler. It appears to function and show the inbuilt sounds.

I guess you have already done this, but load the VST as an instrument (not as audio or MIDI FX).


Now you should be able to hear the chords when clicked on with the sounds selected from the drop down.

If you click ‘MIDI source’ it will switch off the instrument state and you won’t be able to hear sounds. You need to tick the ‘Enable MIDI output’ if you want to feed Scaler MIDI output to a synth.

You need to check that the sounds are in the right place. In Scaler, go to ‘Settings / Preferences’ and at the bottom you will see the sounds location in 2 point text on an unreadable black background.


Check this is where you expected them to be, and where they actually are. The directory should look like this


Once all this is working, it should be straightforward to connect the soft synths.

Hi @Mike4001

Welcome to the forum. I very occasionally use Cakewalk these days having moved over to Live and more recently to Reaper but let me try to provide some additional help on this.

Assuming that you have installed Scaler without a problem with all its sounds then it should be straightforward to open it as a synth in Cakewalk. To get the Scaler sounds as @panda says

Now to get Scaler to trigger your synths in Cakewalk when you load it into a track you should

and ensure that the midi out box is checked on the INSERT SYNTH OPTIONS dialogue

I have found that you have to set the midi output from Scaler to your synth. In the example below I am using Xpand!2 as my sound source which is triggered by Scaler. The routing from Scaler is:

You also should set the input midi routing on your sound source. Here is the screenshot for Xpand!2 in my example:

I’m afraid that I can’t help you on ProTools but I hope that this does help you with Cakewalk.