Scaler 2.8.1 crashes when choosing a scale with unison


I’ve recently updated both Reaper to 6.81 and Scaler to 2.8.1 and now Scaler crashes consistently when doing the following:

  1. What were you trying to do?
  • Add Scaler 2 VST3 as an instrument
  • Set to Scales mode in section A, choose a note, e.g. E, and a type, e.g. Minyo
  • Bind section B or C to incoming MIDI
  • Set Keys Lock to “Scale Notes Mapped”
  • Set Voice Grouping to “Dynamic”
  1. What do you think should have happened?
  • Scaler should work, Audio should play back properly
  1. What happened instead?
  • Scaler’s plugin window becomes unresponsive
  • Audio and MIDI output get glitchier with every note or chord triggered (tried with internal sounds and instruments triggered by Scaler’s MIDI)
  • Finally, Scaler crashes and seemingly takes Reaper down with it*
  1. What system/software do you use?

Windows 10 64-bit, Reaper 6.81, Scaler 2.8.1, MIDI input via Arturia KSP, Behringer XR18 for audio (with Behringer’s ASIO driver)

Haven’t changed anything besides updating Scaler and Reaper - and yes, I’ve already tried going back to 2.8.0 and 6.80 respectively - they all seem to work okay. (To clarify: Scaler 2.8.0 in Reaper 6.80 and 6.81 works fine; Scaler 2.8.1 crashes both Reaper 6.80 and 6.81.)

(* Not saying Scaler is to blame here, it’s just that no other Instrument plugin behaves like this in Reaper, and Scaler seems to work fine in my other DAWs - tested in Renoise 3.4.2 and Live Lite 11)

If there’s any other info needed, I’ll try to provide that. Hope there’s a simple explanation and fix for this behaviour.

Hi @plicktzah

Just been testing this out and it seems to be a Scaler issue as it also happens on Ableton Live 11.3.3 Std and Cakewalk by Bandlab.

For Scaler works without an issue until I choose a scale with a unison and this is the trigger for the crash.

1 Like

Hi @ed66

Thank for the feedback. I’m kind of relieved this in fact seems to be an issue with Scaler. I’m confident it’ll get resolved with the next update.
Are there any steps I need to take to submit this bug report or is this thread the submission?

(Also, I’ll fix the thread title accordingly.)

Hi @plicktzah and @ed66. Thanks for bringing this to our attention. I can confirm that playing unison chords from scales with voice grouping enabled results in a crash. Fortunately there aren’t too many of these unison chords to be found so this is a relatively rare scenario, but definitely a bug which will be addressed in the next Scaler 2 update.

Thanks again.