Scaler 2.8 Crashes in Reaper only if extra sounds NOT installed

I’m running latest Reaper v6.79 on Windows 10. I’ve never had an issue with Scaler before, but when installed the latest 2.8 update it crashes upon opening and takes down Reaper with it. This happens with both the VSTi and VST3i. As soon as Scaler 2.8 opens, screen goes white, then crash to desktop.

Windows Event viewer showed this:

Faulting application name: reaper.exe, version:, time stamp: 0x64457ef9
Faulting module name: Scaler2.vst3, version:, time stamp: 0x646d4fbe
Exception code: 0xc0000005
Fault offset: 0x000000000095b62a
Faulting process ID: 0xe20
Faulting application start time: 0x01d98fecd012b0e9
Faulting application path: C:\Program Files\REAPER (x64)\reaper.exe
Faulting module path: C:\Program Files\Common Files\VST3\Scaler2.vst3
Report ID: c7d4f462-ffad-478d-b052-bac4c7059f34
Faulting package full name: 
Faulting package-relative application ID:

I tried reinstalling, rebooting and a few other things. But one thing I realised, is that I don’t install the extra sounds when I install Scaler (as I use it with soft synths). So I tried reinstalling once more but this time I included the extra sounds. After this, it worked fine.

I’m hoping this might help the devs or other people track down any issues.


Thanks @DanDiplo That’s great and helpful for our devs @Ed1