Scaler 2 - Blacklisted [Cubase]

I just bought Scaler 2, and it doesnt work.

Cubase (9.5 Pro) blacklisted scaler2.dll and scaleraudio.dll
I tried to reactivate them but it does not work.
It says to contact the seller so here I am :slight_smile:

Windows 7 / Cubase Pro 9.5

I have Cubase Elements 10. On my version, it is not blacklisted, but it makes Cubase crash.

I am having the exact same issue. I just purchased and installed Scaler 2.0 and every time I open Scaler 2.0 it makes Cubase freeze completely.

What to do about this - any fixes?

Kind regards
Kim B.

Dear Cubase users,

we are working on a fix for the issue that was making Scaler Audio 2 VST3 to crash on Cubase.

@Hondymion have you tried using the VST3 version of Scaler 2 ?
@scaler2heaven and @KimB which version is giving you a crash ? VST2 or VST3 of Scaler 2 or Scaler Audio 2 ?


@luapmartin all VST2 and VST3 of Scaler 2 and Scaler Audio 2 are giving a crash on my machine (Cubase 10 Elements, Windows 10). I really appreciate that you are working towards a solution. Thanks!

Thanks for the details

Precisions for me:

  • Scaler2.dll is in the same folder as scaler_x64.dll (scaler 1) I tried deleting scaler one .dll (not uninstalling tho) and it does not work
  • I tried copying the license file in the same folder as the .dll and it does not work
  • Itโ€™s an upgrade from scaler 1
  • scaler2.vst3 (located in Programmes/Common Files/VST3) doesnt appear in cubase

I just updated Cubase 10.5.12 to Cubase 10.5.20 and that helped a little. Now it works for a while, but sometimes crashes for God knows what other reason. I think Scaler needs to fix their software, not Cubase!

Also have you installed the latest version of Scaler 2.0.4 ?

There is a known issue that produce a freeze that we are fixing regarding the VST3 of Scaler Audio 2 on Cubase.

Any news about Scaler 2 in Cubase?

Hi @scaler2heaven

we have Scaler 2 working fine here in Cubase on Windows and Mac.

Make sure you install the latest Windows updates and restart your computer.

1 Like

Hello @Ed1
Thanks for the advice. I tried that. I installed 2.0.7, updated Windows, Cubase was already in the latest version. Unfortunately, it is still crashing to the desktop. :cry:

Hello, I installed the last 2.0.8 version and itโ€™s now working in my Cubase.
Thank you!

1 Like