Scaler 2 crashes Ableton Live suite 11

What were you trying to do?

Trying to use Scaler2 on a midi channel in session view inside Abelton live 11 suite. The same issue occurs when I try to use the plugin inside of Audacity as a Audacity.

What do you think should have happened?

The VST would launch and the interface would appear allowing me to use the program without freezing.

What happened instead?’

Whenever I try to launch Scaler 2 inside of Abelton Live 11 suite my computer lags bad, If i move the mouse it can take up to 30 seconds to see a response, sometimes it 100% freezes everything. If I am lucky I can escape the freeze with ctrl + z but usually it will freeze and i have to do a hard reset on the PC. I’ve yet to use anything on the plugin because this happens every time.

**What system/software do you use?

Abelton Live 11 suite / Audacity / Windows 11 Pro 64 bit 22H2 / AMD Ryzen 7 5700G processor / 1 TB SSD M.2 form factor / Focusrite Scarlett 4i4 3rd gen midi interface and sound card / 32 gig DDR4 memory / Radeon RX6000 GPU 8 gig video memory

Please confirm which version of Scaler 2 you are using.

Have you tried reinstalling Scaler?

If you do a search for ‘opengl’ on tis board you will see several similar symptoms. It’s worth checking to see if any match with yours. There can be issues with OpenGL which causes crashes, and the solution is to turn it off.

1 Like

Yes, I confirm it happens, but likely because Audacity is not exactly a DAW, so it cannot accept any kind of plugin as per its FAQ

Take your editing to the next level with an extensive selection of third-party effects plugins, designed by the passionate Audacity, open-source community

So I think you can use third-party effects plugins, but only those created for it

About Ableton, I had it and abandoned it, mainly due to low stability/reliability, so maybe worth testing it in another (real) DAW (even demo)


Cakewalk by Bandlab is still available free and Scaler works in it for me. If you decide to try Cakewalk by Bandlab be sure that it is this product and not Cakewalk Next, which is a Beta development.

I can confirm that I have had no issues with Scaler in Cakewalk (but note @ed66 's comment above).

What’s odd is that multiple people use Scale and Live 11 (including me) and have never experienced the issues that you describe (other than maybe @ClaudioPorcellana , but he has a talent for finding glitches :slight_smile: ) so it’s worth giving what else on your machine might be causing a conflict (I assume that you disabled OpenGL if it was enabled.).


As others have mentioned, you can try to disable OpenGL rendering from the ScalerSettings application. Search on your computer “ScalerSettings” and launch the app, head to the help tab and click disable OpenGL. This should help with the display issue

I confirm that it crashes Ableton Live 11 intro as well

I use it just to retrieve my old Ableton projects, and it doesn’t happen (and never happened) with Bitwig Studio, so no more a problem for me

Scaler 2 and yes I’ve tried that.

Audacity provides the option to use 3rd party plugins. I don’t use audacity as a production station but on a whim decided to try it there. With that said It installs inside audacity as a vst 2 32 bit app (I think) but yields the same result.

2.8.1 is the program version.

:slight_smile: hat we know is that in the majority of cases 2.8.1 works with Live 11 under Windows .

This implies that this combination does not result in a deterministic error. So, there is some other fact with your set up that causes this to happen. I I think the peripherals are not likely to be a factor. I know @ClaudioPorcellana reported a crash, but his PC is less powerful than my mobile phone.:slight_smile: and resource might be a factor there - I don’t know. You have a ballsy box, so we can count that out.

Daft (and probably stupid) question. I’m on a very similarly sized machine (22Gb / EVO 870) but an i9-9900 CPU. Could Ryzen be a cause ? I saw a post about CUBE VST crashing a Ryzen after looking at it on Venus Theory,

Maybe long shot, but the crash you are getting is odd.

Yes, I know that my current PC is still weak :grin:
Too bad I cannot do a testosterone shot in its buttock :rofl:

Nevertheless, Scaler never crashed with Bitwig, and it always crashed with a couple of Ableton releases, so I am more persuaded that the culprit is the combo Ableton+Scaler

1 Like

BTW, I am testing Ableton Live 11 Intro and can say it sees all my controllers that Bitwig Studio truly ignores :smile:

And it also let me use Toontrack Audio Sender that is a godsend

So, apart the possible crashes with Scaler and the lacking multi MIDI-OUT (I found I need it very rarely), Ableton Live remains my preferred DAW