Scaler 2 Locking Up

I am running Cakewalk on Windows 10 Pro. i7 64GB ram and lots of disk. When I run Scaler 2 it freezes usually when I open a drop down box or have been editing. I have changed from using the normal .dll to the vst3 but it locks up all the same. When it locks up I can still use Cakewalk but with Scaler part which locked up and still visible. I can close scaler 2 except for the offending item but when I open it again it shows the front grey pannel with nothing in it. The only way to resolve it to re start Cakewalk. I saw there was an issue with locking upinthe last bug fix but it didn’t work on my platform.
Regards Alan

Hi @AlanV

sorry to hear about your issue, could you please try to disable OpenGL rendering and see if it helps:


Hi Ed.Many thanks for the response.Unfortunately. Still get the same problem it seems if I have been using Scaler 2 for a few minutes and then goto us an item with a dropdown box it freezes the box in place andnothing else works on scaler although I can press play and it plays but unable to re-select anything and the dropdown list box stays open and unable to select anything else.
PS I have checked ScalerSettings and the OpenGLis blanked out.