Scaler 2 Midi Capture Problem

Hello. After I try and capture midi, I drag the clip from the plugin to a new midi track but it always drags in a previously recorded performance. I successfully recorded a midi clip about a month ago, which allowed me to drag it into a new Logic track but now, whatever I do, I can’t stop Scaler dragging that same clip into my Logic project instead of any new midi recordings I create. FWIW, I have reinstalled the plugin and have also tried pressing ‘clear’, as well as stopping midi capture in Scaler before, and after stopping playback in Logic - same problem persists. Any help would be greatly appreciated.

You don’t tell us anything about your setup or Scaler version.
Logic Version
Scaler version
Anything else that might be pertinent.

OS 13.6.3
Logic 10.8.1
Scaler 2.8.2

Thanks. Is there a cache somewhere that stores the midi captures? I’ve tried to trash all related files to make Scaler forget about the previously captured midi but it always drags in the same midi file.

I’ve never experienced this. Not sure I’ve heard of it happening. Hopefully the Devs will chime in here.
So this file is the same as the one from a month ago? Very strange.

Ok, I’ve sussed it out. Looks like it does store a cache of the midi capture and must have become corrupted. It’s not mentioned in the instructions I found elsewhere on how to uninstall the plugin so took a while to find it…

Trash the Scaler-MidiCapture.mid file/s in:
Users/Name/library/Caches/ScalerControl2/Plugin Boutique/Scaler2

1 Like

Good to know. Glad you got it sorted out.

Interesting and thanks for letting us know. We can refer back here if anyone else encounters this. Not sure anyone has but good to know how to clear a corrupt Midi Capture file.