Scaler 2 - No response on one Mac, works fine on the other!

@luapmartin Ver. 2.0.6 downloaded and installed, restarted etc. Issue still present in version 2.0.6 (both 2.0b7 VST and 2.0b7 VST3).

hi @quanta, let me ask you some questions:
Could you try update your Windows 10 Pro to the latest version (Version 2004) ?
Do you have any program that can affect file access (like security or anti-virus…) differently than in your other computer ?
Do you use an external audio interface ?
Could you try with another interface ?
Try arm the track Scaler2 is on.
Try put some midi information in the track Scaler2 and play your daw and check if Scaler can intercept it.
Does the audio detection work ?
Do you manage to route audio into Scaler2 and see the audio meter flashing ?
Are you testing with Scaler2 or ScalerAudio2 ?


Due to Microsoft repeatedly dropping the ball with their updates lately, I’ve been wary of immediately updating.

It’s been better to wait for a few weeks to months until the bugs are sorted out. So, as I have the option with Pro, I had my updates paused.

So I’m still on version 1909 and plan on staying that way for awhile. But even If wanted to update, Microsoft is blocking 2004 update from happening . Welcome to crowd-sourced QA.

But anyway, I restarted the updates, which were paused and it installed Quality Update KB4549951

After restart…Scaler 2 works!

Dunno if installing KB4549951 is what fixed it. Maybe having updates paused in Windows Update prevents some other change to system configuration happening. Reminder that maybe because of this setting, I didn’t get any runtime installation on my desktop after I first installed Scaler 2, but did on my laptop. There it prompted a restart and Scaler 2 worked from the get go. Also, as the laptop is version 1903, there’s no KB4549951 to install, so due to that I don’t think KB4549951 is the "fix itself but having Windows Updates not paused.

So to conclude, if you have updates paused on your Windows 10 Pro, unpause them and let Windows update, restart and see if Scaler 2 starts working. @luapmartin

PS. PEBCAK! :smiley:

1 Like