Scaler 2 Upgrade from Scaler 1 Crash On Studio One

Hi, I already had an Scaler, and I decided to buy the ‘ Scaler 2 Upgrade from Scaler 1’, instead. I have followed the installation process as usual but when I load it on StudioOne4, this one crashed down!

Please, let me know how to fix it. Thanks!

Hi,I’m the just similar symptom, too.

1 Like

Thanks for reporting, sorry you are experiencing this issue, we are having a look at this now.

1 Like

Today, I received an answer this answer from my supplier, but still having the same issue. I bought the Upgrade versión because I already had Scaler 1

Thanks for your quick response!

Hey! That happened again, today!!!

Yes I’m having the same problem with Scaler 2 Crashing and I’m using Studio One 4.6.1 ALSO Same thing in Cakewalk. We need a fix.


Ver2.0.5 has come via Plugin Boutique, but even if it’s installed, the same symptom has gone out.

Hi Ed,
Definitely, Version 2.04 neither Version 2.05 don’t work!

I made an experiment.

  1. I uninstalled my Scaler 1 from my computer. 2. I bought the version 2.05, as well.
  2. I opened it on Studio One 4, crashed down! 4. I opened on Ableton Live 10 Lite, crashed down, too!

Now have another problem.
I have to reinstall my Scaler 1 again.
I bought the Scaler 2’s two version, and both crashed down!

Do you already have the solution to solve these plugins’ issues?


The phenomenon angry with me will be reported to Plugin Boutique.(with Studio One crush data)
And a contact of an update to ver2.0.6 had come, so it was carried out.
But the situation didn’t change.

The sent report is as follows.
・ my system OS version report
・ my Studio One version report
・ Scaler2 install screenshots
・ Studio One crush dmp file

Scaler 2 ran with no issues on AKAI MPC, but on Studio One 4 and on Ableton Live 10 Lite, still having problems.

1 Like

[An Unexpected Error occurred in this Application or one of its Plug - ins!]

I have the same problem in Studio One 4. I’m a little concerned that there isn’t a solution here.

The plugin is installed, it appears in the instruments. When I try to put it in a new track it comes up with just a black window and the above error pops up identical to the image of the original poster. Since I can’t get in to apply the registration key, it will make the white noise sound of the trial version.

1 Like

We are having a look at this. I will update when I get more info.

Same Here! Need help scaler 2 keeps crashing in studio one 4

1 Like


It started to move in case of next doing indicated processing.!!

VST2→An error message goes out, but when clearing and putting out a message, it moves.
VST3→An error message doesn’t go out, and normally moves.

I don’t know whether this is right correspondence, but please check the cause continuously.

The Upgrade Scaler 2 Version 2.06 doesn’t work as well.

Hi all,

With $ in hand, I’m attempting to test drive the Scaler 2 trial to make sure it works for me. Unfortunately, I have also encountered significant problems like the ones listed in this thread.

Specifics: I downloaded the Scaler 2 trial yesterday (Macos Catalina) and after installation it opened ONCE in Studio One 4.6 with no problem. But after restarting “S1”, Scaler consistently crashes S1 (and with S1 set to bring up load last song, S1 was rendered inoperable). Tried bringing up Scaler in Ableton Live 10 Lite and it crashed the program as well. Had to manually delete Scaler 2 as best as I could. (*)

I do hope I’ll have some time left in my trial period so I can test it before buying. But I do look forward to a fix as it looks like a decent product.

*–PLEASE PLEASE PLEASE include an Uninstaller. There are many normal scenarios where you’re leaving users stuck with extra software on their computers after a trial (successful or not), when moving to another computer, etc. I uninstalled manually–but don’t know if I got everything, making testing a bit dubious for both of us.

I’am using studio one 4 and iam have alot of problems with scaler 2.6. it does not work when I reroute it to to use with Vst like Omnisphere keyscpace etc. It also cash my studio one 4 projects. Please help thank you

Hi, today I uninstalled the Version 2.06 using Windows 10’s Control Panel, and I ran the Version 2.07 on Studio One 4 and on Ableton Live 10 but NO VST’s image! Now them are dark! Still the issues.

Just to say, that it run well on AKAI’s MPC.

Reinstalling using default path plus rendering and font settings hacks solved issue for me in Studio One and Reason…