Scaler control doesn't work on my midi fx, but works when I insert it in my instrument track

I just bought the new version of scaler, it doesn’t work IN MY LOGIC X when I load it in my MIDI FX slot

I basically pull up my instrument track then load the software stock piano in the “instrument” slot, then load the scaler control in my MIDI FX, however again it won’t respond, and my piano doesn’t respond.

I tried to load scaler in my MIDI FX first then load my piano but it still not responding


Hi @Pswazy,

this sounds like the MIDI bus is not active. This happens with MIDI FX in Logic Pro.
You have to add Scaler as a MIDI FX and an instrument to be controlled on the same track. Then try to send some notes to the track by selecting it and pressing keys on your MIDI keyboard.

Until you actually send some notes to the track, Scaler UI will not respond to clicks and it will not play sounds.

I hope this helps,


Thanks for the advice but unfortunately it still doesn’t work, I am thinking I should reinstall the plugin

I got the same issue mentioned in this thread

When you have it loaded as you say, press COMMAND-K to bring ups the Logic music keyboard and press some notes. Scaler should be responding.

ya i have the same problem. works fine as an instrument but doesnt respond as a midi fx. Any help would be great.

did you get a solution…I’m having the same problem

any sloution ???

Nope, still no solution…

thanks for getting back to me anyway :+1:

Hi ya I’ve done that. can use logics native midi fx no prob just not scaler it dosent seem to be recieving midi data or outputting it.


Are you sending MIDI notes from a specific channel ? Also you can check which MIDI channel your instrument is listening to.

Just trying to understand what could be going on as it usually works fine as a MIDI FX.


I’m having the same problem. Just installed Scaler 2 in Logic Pro X and cant get any sound output at all. Even when clicking the piano keys in the built-in piano roll or the ‘play’ buttons in the Scales section i can’t get sound. This is very frustrating. Any help?

1 Like

Same Here!! no audio at all not through midi fx or as an instrument

I don’t think the plugin works as a midi fx,

It should work as simple as that but it does not at the moment.

1 Like