Scaler Not Launching from Plugins menu in Ableton

I am trying to launch Scaler 2 from the plugins menu in Ableton (I have Ableton 11.3.3) however it is just the spinning wheel of death and a white screen/ it keeps freezing/ crashing my Ableton and I have to reopen Ableton again after. I shut down/ restarted my computer to see if that would help, but no dice. Can someone pls help?

We need more information.
Scaler Version
Did this just start happening? Did it work before and now it doesn’t?
If it worked before did anything change?

Welcome to the board. This is a good place to help help from seasoned users

First off, though, it’s useful to post your op system details, as this will determine if your are most likely to get responses for Windows or Mac folks. if it’s Mac it also helps to say wihch variety of system and which chip (I don’t understand this, but it seems to make a difference with |Apple stuff :slight_smile:

You need to say which version of Scaler you are using. Here’s what the process looks like under windows.

You should see Scaler under Plugin Boutique in the vst3 plugins list


Drag the plugin into a midi track

The plugin should show in the instrument area. Click on the spanner to load up the plugin.

I’m presuming you have done all this … at which point did it fail ?

Hi, thank you for the response. Yes, I see the Plugin via the VST3 menu drop down, and I did already drag it onto a Midi track, but no dice. (I also tried restarting/ rescanning plugins). Any ideas?

Further info regarding the OS:

Processor: 11th Gen Intel(R) Core™ i5-11400H @ 2.70GHz 2.69 GHz
Installed RAM: 8.00 GB (7.75 GB usable)
Windows 11
Version 22H2
OS Build: 22621.1702

Thank you for the response. No, it never worked for me yet. I see it in the plugin menu, but it does not work when I try to load it onto a midi track. (See my response below for info re: OS)

Try turning off openGL - Search ScalerSettings from start/search in Windows and turned off OpenGL in the Scaler/Settings App. You didn’t say when you bought and downloaded Scaler. What version did you download?

I just bought/ downloaded off the plugin boutique. I am trying to turn off OpenGL, but not seeing where to access the settings. When I tried to search in the menu nothing came up. (See below.) Am I missing something? Please let me know when you get a chance. Thanks again!

It’s not in your applications folder…
On Windows…
You can disable OpenGL Rendering from the ScalerSettings application:

  • Press the Windows key to open the search and type “ ScalerSettings ”
  • Go to the Help page and click “Turn OFF OpenGL”

Maybe this is clearer…
In the Windows search bar, type Scaler, then click on the Scaler Settings icon.

Go to Help. Turn off OpenGL by clicking on it.

So what you are looking for is ScalerSettings.exe

1 Like

It worked! Thanks for your help!

1 Like