Scaler stop working on duplicate track on iMac M1

I have a problem with Scaler 2.4.1 and Logic 10.7 on iMac M1 (Monterey)
After creating a track and adding Scaler as a Midi Plugin, if it is duplicated it stops playing and the midi information is received only from the duplicated track.
:thinking: Maybe it depends on Logic’s new midi routing system, but I haven’t found any documentation about it…
For clarity, I have posted a video

Does anyone have the same problem?
Is there a way to fix it?

Hi @Pinzer

thanks for reporting.

Logic 10.7 seems to have fixed some issues on M1 but not everything.
Have you tried running Logic with Rosetta?

Yes, it happens with Rosetta too … but I did some tests and it happens with other third-party “Midi FX” plugins too. :disappointed_relieved:
With native “Midi FX” everything works fine.
I tried to report it to Apple … let’s hope so!

I’ve seen the same, any 3rd party midi FX seems to stop the midi getting through to the instrument.

I’ll bother Apple about it too!

Thanks, Blorp!
We hope others do and Apple fixes up quickly.
I use Scaler very often and right now the workflow becomes complicated …

But you know, every update solves some problems and creates others !! :unamused:

Very frustrating and the reason I can’t progress all of our studios to M1’s. Also a reason I think the next MacPro will be Intel based. Reporting to Apple is a good idea.

I agree, I am a hobbyist so I just have to “curse” a little and get around the obstacle, but for those who work as a pro, updating too early is never good!
We hope Apple will solve it soon!
fingers crossed