Scaler window stays on top in Reaper

Hey, all. I’m using Win 10, Scaler 2.7.3 in Reaper. When I add Scaler, it loads into an FX window, and it seems to be set to “stay on top,” and is way too obtrusive. I can’t find a setting to make it behave normally. It doesn’t keep focus, just stays on top. No other VST does this for me.

If I float Scaler (remove it from the FX window), it behaves normally as far as window layers go.

Wondering if anyone else has seen this, and hopefully a fix?

Can you send a screen shot of this situation, please?
Also, which version of Reaper do you use?

Thanks for the reply. This came out pretty fuzzy…
Reaper v. 6.79. It is intermittent at this point.

TBH I have never seen such a behavior in Reaper. As the image in your clip is very small, I cannot see the details that you have in Preferences.

I was unable to reproduce the issue, so at this moment, I suggest you a workaround, to set the Action to toggle the FX window for the current track:

I have a question. You wrote that when you add Scaler, it loads into an FX window. How do you add it? Do you drag Scaler to the existing track or to the empty space and Reaper creater a track with Scaler as FX?

I almost always use menu/ Insert virtual instrument on new track. I’ll check out that action. Opening the Preferences window was just to show that Reaper’s own windows don’t even open on top. Right now, everything’s behaving :slight_smile:

I too have not found this an issue, which suggests there may be something in your configuration that is causing this. I know you said

but could I clarify a couple of points:

  1. Is your Scaler track the first track in your project?
  2. Do you find this happening if you have another synth as the first track in your project
  3. This does not happen to a synth on any project which does not include Scaler.

Have you raised this on the Reaper forum to see if anyone else has had a similar issue?

Thanks for those questions.

I’ve checked track order to find it only happens when I load Scaler on the first track. Any other first track, even empty, and Scaler is fine,

Looking for other synths that may have this behavior, I found that 32 bit VSTs, which all come in bridged, behave like this also. Otherwise I haven’t found any.

This seems like Reaper bug with some VSTs, but it will be difficult to find out why. I have never thought about and do not remember if there was a 32-bit version of scaler. If so - is this the one you installed?
A stupid question, maybe, but I have no other clue.

I think Scaler 2.7 is 64 bit only, ie there is no 32 bit version.

But was Scaler 1 available as a 32 bit vst, and did you, @micT, install this originally and then upgrade from it? If so, there may be an old bit of code “hanging around” somewhere that is causing this issue (an ini file maybe?). Perhaps the tech team could comment?

I started with 2.7.0, no previous installs. Avoiding the first track is the workaround. Interesting that you asked about that – I hadn’t been aware that was a thing :slight_smile: It would be nice to know the “why,” but this works. Thanks to you both!