Scaler2 2.7 locks up Studio One v6

I found the following problem a few months ago with S1 v5 and S2 v2.6 but I just gave up. Now I have updated to S1 v6 and S2 v2.7 and I find the same thing. I’m on Windows 11.

I can put an instance of S2 on a track and do various tasks including routing MIDI notes to a synth on a separate track. If I pin the S2 window open, I can add another instrument, but if I do anything that causes the S2 window to be hidden (e.g., open another instrument when S2 is not pinned open), S1 immediately locks up. It’s as if the contents of the S2 window are erased or lost.

If I keep the S2 window pinned so it is never covered by another plugin, I can get farther, and even save the song. But if I close and then reopen that file, the S2 window opens all black (no settings), and Studio One immediately locks up (process must be killed in Task Manager).

I really like Scaler2 and I am trying to learn to use it for composition. I have a partial workaround with the S2 iPad app. I create a progression with performance in Pad view and play it with Capture MIDI. I then export that as a MIDI file, email it to my PC, and drag it into a S1 instrument. This is better than nothing but I want to make changes with the S2 controls inside Studio One, not only edit my imported MIDI notes.

Any ideas? Everything else in Studio One is working well for me (mostly S1 features and Kontakt instruments). Thanks!

Welcome @FlyingSinger This is hurting my head just thinking about what is going on there. Can’t say much for S1 as it’s legacy but let me have some people check the S2 behaviour on your setup here and get back to you @James @Tristan
In the meantime please check through this entire thread to see if it helps:

I think when the OP says “S1” they mean “Studio One” not “Scaler v1”.

1 Like

Thanks for the reply! I scanned that thread and didn’t see anything I understood. I don’t know where OpenGL fits in all the layers here. Sorry for confusion with abbreviations. I always use S1 for Studio One and S2 for Scaler2. I was surprised to see the problem persist across updates to Studio One v6 and Scaler2 v2.7. Makes it seem like it’s my PC (a 2020 Alienware gaming desktop with Win11). I suppose one thing I could try is to install my DAW on the gaming laptop I just got for VR with flight sim. It wasn’t my plan but they both connect to the same peripherals.

You should really try turning OpenGL off. That black screen sounds exactly like I’ve seen.

Hey Bruce, welcome.

I’m trying to repro your issue now with no luck yet. I’m on S1 v5 with S2 2.7 and an older Win 10 machine. It definitely sounds like a graphics driver issue but where and why is anybody’s guess…

Here are areas I’d start tweaking to see if you can get it stable or reproducible in a very specific way.

In S1:

  • Hi DPI setting in Options/General
  • Are you trying both the VST2 and the VST3 versions of Scaler. One of my DAWS does not like the VST2 version

In S2
Anything that impacts graphics…long list I know

  1. Blink effect
  2. Font Size/Face
  3. Color
  4. View size
    others I’ve missed.

If you can reproduce the exact failure steps, let us know and someone might have some ideas.

Good luck…it is time well spent!

Well, something seems to have worked! I sequentially changed the things you suggested first in S1 (no effect) then turned off Blink and at first no joy, but then I fiddled with View Size, Font Size, etc. and made several simple test files and restarted S1 multiple times. I don’t know exactly what finally clicked after 10-15 failures because I also started waiting 30 seconds before interacting with plugins after opening a file and I also turned off the “splash screen” when S2 loads. Once S1 was opening without lockup, I started trying things in S2. So far it seems stable.

So thanks very much! I wish I had been more systematic but I was getting impatient. I need to do more tests tomorrow including a full PC reboot, but I’m optimistic. I’m still confused about what’s controlling what, but that’s just learning curve. I’m already getting a lot of cool sounds. :+1: :grinning:

UPDATE: I think I found the real problem. Everything worked this morning until I happened to drag the instrument window over to my second screen (last night I was testing all on my big 3440x1440 gaming monitor). When I selected the Scaler2 tab in that window, it opened all-black, and Studio One immediately crashed.

So it seems to be a multi-monitor graphics problem (NVIDIA RTX 2070). If that holds up, it’s easy enough to keep all instances of S2 in one window on my main monitor with the main S1 window, and use the second screen for Kontakt instruments, effects, etc. I may research the multi-monitor aspect but as long as the workaround works (it will require a PostIt Note on the monitor to remind me!), it’s low priority.

Just FYI and thanks again for the help!

Glad you found the crash scenario…and thanks for the update. Those pesky graphics stacks!

Any chance you tried both the VST2 and VST3 versions to see if you get the same results?

It fails on both.

I did all my original testing with the VST2 plugin. Just now I set up a simple new “song” using the VST3 plugin. Initially I parked it on my main monitor and it behaved normally. I pinned it open, opened an instrument in another window, and played that instrument from S2. Then I added another instrument which became a tab on the S2 window (I’m not sure how Studio One allocates these things). While on the main display, all remained well. When I dragged that window to my second screen, it was OK with the instrument on top. But when I clicked on the Scaler2 tab, a black space briefly got focus, then Studio One stopped responding.

My mission is to keep Scaler2 only on my main screen! And save often for when I forget. I usually keep my instruments and effects on the second screen and this is the only time I’ve seen a problem with hidden tabs or windows for any software failing to operate and refresh (and crash the DAW).

Thanks again for the update. I’m still on S1 5 and might update soon. Knowing about this potential issue will make it much easier to manage.

Not sure if your solved but I had to right click studio one 5 icon, click properties, compatibility and change(tick) high dpi settings to Overide high dpi scaling behaviour(enhanced). I use a Nvidia rtx 2070 too. This might be the same issue in version 6 but im still waiting for a cheap upgrade price.