ScalerAudio 2 No Sound in Logic Pro

Haven’t seen this issue discussed except in an old post but the solution didn’t work for me.

I’m using Logic 13.0.1 and just updated to Scaler 2.8.1, but the problem also existed on the earlier version.

The issue is when I load ScalerAudio 2 on an audio track in Logic, no sound is generated from the plugin. If I play the virtual keyboard for example there is no sound. I have tried with record enabled and with input monitoring selected. I have also tried changing sounds. Note: this problem does not occur in Ableton. The midi version also works fine (in Ableton and Logic).

I would appreciate any suggestions for a fix.


Scaler Audio is used for detecting chord from audio. You want to use Scaler 2 as an instrument. Look for that under the instrument insert on the track you create. Also since Logic is AU only, to get Scaler to send chord info to instruments you need to use Scaler Control. Look for that under MIDI FX.

Thanks for the suggestion. That’s actually what I’m using the Audio Track instance for, to detect chords from a piece of audio. The issue is I can’t check the detection because the chords detected don’t play back through the plug-in. In Ableton, once the audio has been detected I can then listen back to see if the chords Scaler suggest are accurate. Logic won’t let me do that. I’ve seen Davide do this in one of his videos so I know it should also work with Logic. Any other ideas would be appreciated.

Hey @JJStyles Welcome to the forum. You should be getting a little pop up in Scaler when loading it as an audio FX - ‘enable input monitoring in Logic to hear Scaler internal audio’ or something like that! So just hit the ‘I’ next to the record button on your channel in Logic and you should be good to go!

Hi@davide. I don’t get a pop up when loading ScalerAudio as an audio FX. I have however tried enabling input monitoring (‘I’) but that doesn’t help. As I mentioned earlier, it works fine in Ableton, just Logic that seems to be the problem. Would you recommend I delete and reinstall the application?


I do actually get a little pop up in Scaler which says “Scaler Audio:Ensure the track is armed in order to playback chords.X” Still no sound though.

Problem Solved! I somehow managed to switch software monitoring off in Logic Preferences. Sorry for any inconvenience caused. Love the PlugIn by the way.

1 Like