Semi hang on ipad air 2. Please help

All windows in the scaler are difficult to open or close.( Like being stuck ) . Every icon that I press shows a hard reaction . It seems that the scaler 2 is semi hang . Both in standalone mode and in plugin mode AU . The scaler does not work very smoothly and easily and quickly. Although my cpu meter in cubasis is very low when using scaler as AU instrument or AU midi effect .

Ipad air2
Ios 13.3
Scaler Latest version.

Is there no one here to answer? this is really annoying. I installed the new version ( 1.2 ) but the same problem exists again . Pleas help .

Hi @pejman The reason you may not be getting answers is that I am not sure anyone is running iOS 13. Have you considered updating your OS to something more recent? Have you tried Scaler in standalone as a process of elimination? Should work fine

Hi david.

Thank you for your attention

I can’t update my ios for some reason. Yes, I have tested the scaler in stand alone mode, but unfortunately it has the same problem . It is written like this in the information about the Scaler in the App Store :
Requires ios 11 or later .

Hi again

I have updated my ios to 15.7.1 but there is still same problem. ( semi hang ) please help.

Ipad air 2
Scaler 1.2
Ios 15,7,1

Have you tried deleting the app, restarting the iPad, quitting out of all other apps and reinstalling Scaler fresh? Should be no problem with your setup.

Hi Davide

I deleted and reinstalled scaler twice before installing the new ios ( 15.7.1 ). I did this twice after installing the new iOS . But today I did the steps again as you instructed, but the problem is still there .

HI @Pejman To be fair that iPad is 2014 and is a non supported legacy device as listed by Apple. It’s pretty old and hard to diagnose. My son has the same iPad and he uses Scaler on it without any issues. It could be numerous things but as you can appreciate very hard to pinpoint. Apple’s expects our app to work on supported devices which it does.

Hi Davide

I have over 170 music apps ( Daw,s , effects, plugins, midi apps , …. ) on my iPad now, They are updated regularly and I use them easily , without any problem. Now the only app I have problems with is scaler .
Regarding the fact that it says that my device is old and not supported by iOS, I would like to say that , Apple released iPadOS 15,7,1 In 27 October 2022 , That is 2 weeks ago . It also supports iPad Air 2 . It means that my device was supported by iOS until 2 weeks ago . In addition, you have written in the information section of your software in the App Store: compatibility: iPad , Requires iPadOS 11 or later . and I have used your software based on this information . Therefore, your speech is not justified for me .
With all these interpretations, don’t you think that your software has a problem with my device ? Something like buffer size. or latency.
Please support me.

Try turning off the audio detection off by clicking the AUDIO top left and see if that improves performance. Maybe the lead developer @Ed1 may have some thoughts for you.

I did this ( turning off the audio ) now but unfortunately nothing changed. There is still same problem.