Sizing bug/Feature request

I can use this plugin once. If I open the session again, and want to adjust it, I can’t because the screen becomes HUGE, and there is no way to resize it, and I can’t see any of the controls on the bottom.

Also, for the feature request, this plugin really needs a mix% dry/wet knob, and automatic gain compensation.

Try this - Open the stand alone Scaler EQ - Scale it down to a reasonable size then click on the gear on the upper right of the GUI and choose GUI set as default. It worked for me on my Mac. Most people don’t know there is a stand alone that gets installed. At least on the Mac there is.

Even after the latest update, it still does this! No other plugin has this issue. It starts off as normal size. Then I better like my settings, because if I ever view the plugin again, it is huge! I can’t even see the stuff at the bottom, so I can’t adjust any of it. I should get my money back for this since I never can use it, even after the latest update.

Hey @BeatsbyIQ Have you tried @jamieh suggestion? We have actually noticed an issue that we think is related to a preset we made and the size being rescaled. But closing and reopening fixes it and should be no further issue if you save as default other than the preset based size issue we are looking at.

1 Like

There is no standalone Scaler EQ that got installed. I put a new instance of the plugin on a track. The size is fine. I went to settings>Gui Size and clicked ‘set as default’. Then I saved and re-opened the session, but my other scaler EQs are still big and I don’t know how to shrink them so I can see the settings at the bottom.
At first it looks like this:


Then it looks like this:

1 Like

Ahh I think we have an issue with the new presets we made for Scaler EQ 1.1 update. We made them on an interim beta and it seems reloading them is causing this issue. This is on our list to get to. I am assuming it doesn’t happen in a blank EQ on a vanilla session (no preset)?

1 Like

@BeatsbyIQ I’ve DM’s you a new installer to check please, we think we have found and resolved the issue. Not from our DEVs:

‘Try this one for a fix for the preset resizing issues. If you had a plugin instance that keeps opening too large this should limit it so it is never bigger than your screen (not account for the different sized top bars in various daws). This fixes issues where someone has already saved their plugin too large in the session and can’t resize it. However once this version is installed, loading a preset should never alter the size upon reopening. I just added the maximum size check so users wouldn’t have to delete and create a new Scaler EQ instance to fix this issue’

1 Like

It looks good so far. Thank you!

1 Like

Scaler EQ 1.1.1 being uploaded to Plugin Boutique next few weeks with a fix for the sizing and windows temp dir issues.

Hi again. Actually, just thought you might want to know that I just went to an old session and opened a scalerEQ that was already there again, and it still is like this. I bet I had an EQ curve on this too. I didn’t really test it right the first time since I wasn’t sure what old sessions had it, so I tried it with a new instance and reopening the session, which seemed to work fine.

If you fixed the issue with any new instance, that’s great, but this is still not behavior any other plugin has that I’ve seen. And I have a lot of plugins.

Here’s another one from the same session.

Mine was stuck big for a few weeks recently too. Then a few days ago it just resized itself. I’m still on the beta so probably not hugely relevant.

I just installed Scaler EQ on Windows 11 using FL Studio and I’ve got the same huge window problem going on as is described above. I hadn’t installed the standalone app (which seemed like a nifty workaround), so I installed it, but that doesn’t work for me either. I can resize the window horizontally, but the top of the window is off the top of the screen and likewise the bottom of the window is off the bottom of the screen - so no window grabbers are available for resizing.

Any suggestions as to how to get past this issue, as it’s a complete “showstopper” currently.

Hi @BeatsbyIQ and @britgeek. We’ve done some testing here with Scaler EQ on Windows 11 and the window size seems to be fine when working with monitor resolutions of 3840p or 1440p, however it can appear too large with a 1080p resolution. Can I just check with anyone seeing this issue whether or not they are using a 1080p monitor resolution? Thanks!

I use a couple of different configurations, but on the one I am using this morning, I am having the problem on both the secondary monitor (which is indeed an old 1920x1080 resolution) AND on the primary monitor (which is a 2256x1504 resolution laptop).

I’ll try the other one later today (and that was the one where I first saw the problems on), but from memory I am absolutely certain that the monitors on that setup are all > 1080.

Well, I need to eat my words - the three monitor setup is indeed 2x external monitors at 1920x1080. The primary monitor is bigger though, so it shouldn’t supposedly be happening there.

That said, while older monitors of this resolution might not be purchased much any longer, there are still lots of them around, and those users of them (like me!) need to have a viable way to use this software, This is literally the only plugin where I’ve encountered an issue like this.

This is mine. I’m on windows 10 Home