Stuck midi notes on performance - Scalar 2.8

Ever since update to Scalar 2.8 I get stuck midi notes, doesn’t matter if I hit midi panic or do various settings, notes will get stuck again. I uploaded a video here

I am using Ableton 11.3.2. I tried various settings like quantize, and latch and still same result. Midi panic only works briefly then another note will get locked. This does not happen when playing the chords only when doing Performance, Phrase, Bass, etc.

Yes, same problem with 2.8. and Live 11.3.2
Panic button does not help.
To solve this you need to shorten the length of the notes in Ableton.

It’s only when you send midi from scaler to vst.<<<<

Never had this problem with earlier versions,
I will uninstall this 2.8 and go back to 2.7.
Because when opening projects with any earlier version as 2.8 will end up with stuck notes and have to manual adjust.

Welcome to the forum @john7 We are looking into this as much of our testing is fine, although we are wondering whether this is an issue on M1 Macs. Can you and @wren confirm your platform? Macs M1?

Yes, running Macbook Air M2 2022 MacOS Ventura 13.2.1 (22D68)

Windows 10 home, Ableton live 11.3.2

Difference from all other Scaler version is have to disable monitor in Ableton and have to shorten the notes when legato in midi clip Ableton even when no overlapping notes, tested this with performance modes in Scaler 2.8.

As stated, never had any problems with any version of Scaler.

I’m using Studio One & Maschine and it happens in both, shortening the note works, but that’s not a solution when your composition requires a lengthy note. Is that the fix ? To not use long notes ? It’s a bug, not user error. The issue didn’t exist before 2.8. I’m wondering why this update was released…do you hire testers to find this type of “ship issue” ?

@davide Hi any update on this? I am still using 2.8, and for new and existing projects I have been shortening the midi notes, but it’s an annoying workaround. If I start/end quantize midi notes I will get this issue. And sometimes the progression misses a note since there is a gap.

I Initially assumed it was an M1 issue, but I just tested on my intel machine and the same thing is happening. Both in Logic and Protools, on both M1 and Intel.

Mac Studio M1 Pro / MBP Intel i9, Protools 23.3 and 23.6 / LPX 10.7.8 and Ventura 13.4 (both machines)

Welcome to the forum @chrisblancato I believe this is being rectified now along with some other fixes for an imminent 2.8.1 update which we should have ready soon @Ed1 @James @Tristan

1 Like

Awesome! Thanks @davide