Stuck notes in Scaler 2.4 - never had them before

Until now I’ve never experienced stuck notes in Scaler except rarely and usually user error. Now I am getting them almost always several times in a session.
OS 10.13.6 iMac
Scaler 2.4
Happens in Ableton 11 and Gig Performer 4
Very odd as it is happening so often now.

Hey Jamie

Not sure if this might help, but maybe worth looking at…system resources. I run Scaler on a handful of Windows machines and one of them is an old & slow laptop. While I’d get a hung note once in a while, generally that was the exception. However, I’ve been getting them more often but I’ve also installed a couple new synth VSTs that are pretty resource hungry. Now, if I get hung notes and I look at my resource usage, I’m generally pushing memory and/or XPU resources beyond what I was before.

just a thought…

Yes that’s a possibility. One instrument was Piano Colors as it’s cpu hungry. Still not sure why that should make Scaler act that way unless it’s interrupting the note off signal somehow.

Not sure if it’s relevant, but I’ve been suffering hung notes on some performances etc for quite a while. I’ve found that when you’ve recorded the midi to the (Reaper) Daw midi track make sure that the notes in each bar actually do end at the end of the midi section, or even shrink all of the notes to be a tiny bit shorter than the full length of the note. and sometimes it is quite useful, but I prefer the notes to finish where I actually wrote them to.

Hi there,

same issue here…
It happens ALWAYS, and also if Scaler 2 is the only VST loaded into the DAW.

Windows 10, Studio One 4, Scaler 2.4, Windows Audio (Not ASIO)

My Observations:

The Note hangs when using “Perform” Mode.
I can stop it by pressing MIDI Panic button.
It seems not to be a controller issue because it happens also when clicking the chord itself in the UI.
The Note is stuck after the first repetition of the pattern. (When the pattern repeats)

I am looking for help…



thanks for the feedback and info on your different configs. We are having a look at this issue right now, we’re hoping to find a fix we can push in 2.4.1 which is due really soon.


FWIW…Been there, done that for years.

I run Scaler on 3 different PCs from 8G to 32G with 3 different brands of midi controllers and 3-4 different DAWs and the common thread with stuck notes is the Windows Audio Driver and latency settings in your DAWs

Definitely worth getting off Windows Audio and onto the free Asio4all or a dedicated AI.

Good luck

Doesn’t explain stuck notes on the Mac as in my case.

yeah…sorry should have @scaleme’d my last post.

Alright, checked that

With ASIO4ALL no more stuck notes on my System.
But what if I dont want to use ASIO ?

Hope this Info is somehow helpful for the Devs…

@scaleme What´s the reason NOT to use ASIO? (I´m on mac now but have been working on Windows many years though)

On my Windows 8.1 the ASIO drivers lock audio to the DAW for exclusive access, and I can’t play back any audio source outside of the DAW (like web browser, or even media player). That is a nuisance at times when I try to record from audio sources on the same system.

1 Like

With Ableton Live 11 on Windows 10, I find that MME/DirectX mode with the audio output device set to “Realtek Audio DX” is more stable at lower latencies than ASIO4ALL (which I’ve always found pretty flaky). And then there’s the ASIO4ALL exclusive problem that @Bernd mentioned - I want to be able to watch tutorial videos while following along in Live. :slightly_smiling_face:

I don’t know about other manufacturers, but Realtek has come a long way with their Windows drivers, to the point where ASIO4ALL is (at least in my experience) unnecessary. Definitely worth some experimentation, YMMV.