Studio One 6.6 problem with Scaler

Hi, first post.

Today I have upgraded to Studio One V6.6. I’ve previously been using Scaler with Studio One V5.x and it’s been fine but it is not fine with V6.6

The plugin loads and displays but only partially works. The symptoms are varied but consistent.

  1. I can browse and select a scale and play that scale by pressing the on-screen “pads” but if I drag a pad down to section C it shows a glitched graphic. You can play the pad but you cannot drag a new on to it.
  2. You can’t get to the settings menu. You click on the little “cog” but nothing happens.
  3. You can’t get to the sync screen. You can get to the system menu but when you click on sync nothing happens.
  4. The default instrument “felt piano” plays fine. If I select any other instrument the list box shows the new instrument but the sound is still the felt piano.

I tried a few other VSTs to make sure there was not something bigger happening but they were all fine. I tried disabling the OpenGL in Scaler 2, because I know that has solved problems for people in the past.

This is the latest version of Scaler 2 on Windows 10. I’m very familiar with the program and I use it regularly in Studio One V5.5 so it looks like this is a Studio One V6.6 problem but I wondered if anyone else has seen this or can test for it. I’ve already put in a ticket to Presonus but from experience they are very, very slow to respond and they almost always blame the “other thing” as a first response so I’m not very hopeful of a quick resolution.


I also encountered a similar phenomenon. When I inserted Scaler2 into a new project, there seemed to be no problem. It might be a problem on Studio One’s side.

VST plug-ins can be used on macOS, but I have not tried them.

Studio One 6.6
Scaler2 2.1.8 (AU)
macOS sonoma 14.4.1 (newest version)

Mine is on Windows 10 and a new project makes no difference.
I start a new blank project in Studio One V6.6 and drag one instance of Scaler 2 into it. Same symptoms as I described above. The easiest test is to press the Settings Icon (the cog). It animates but the settings menu does not appear.

Scaler V6.6 was only released yesterday so maybe we’ll see a few more people with the problem and, hopefully, a quick solution.

Anyone using the VST 3 version in Studio One?
For some reason it cannot capture/recognice input from a track.
For the VST2 version this is not a problem.
Is this a known problem?

Thanks. robert glotzbach

I’ve encountered a different incompatibility between Scaler 2 and the upgraded Studio One 6.6. I’m using a Mac M2 and the most recent OS update, 13.6.4

Any use of the Scaler VST3 plugin in Studio One 6.6 gives me a periodic “crashing wave” sound that typically identifies that a demo plugin is in use. This is occurring with new compositions when I drop Scaler onto a track, as well as with older compositions where I’ve got Scaler on one or more tracks. Each “wave” lasts 9 seconds, with a gap of 20 seconds between waves. Even when I remove the track, the wave sound continues. It’s only when I disable Scaler in the channel or remove it entirely does the wave sound stop.

It doesn’t appear to happen with the AU version of the plug-in, nor the VST2 version. Only the VST3. But it remains very annoying because all my earlier work using Scaler now gets disrupted by this crashing wave sound.

If anyone discovers a workaround I’d welcome it. I’ll also post in the Presonus forums.

Experiencing the same issues here with SO 6.6 and Scaler 2.8.1. Program goes into demo mode (hence the hissing) and menus are unresponsive. Also dragging cords from Section A to Section C resulted in “double vision” graphics. I have also posted to the Presonus Forum. I am on a MacBook Pro M1 computer running macOS 12.7.4. In the meantime I have reverted back to Studio One v 6.5.2 and the issue goes away so it is definitely an issue with Studio One. I am using the VST3 version of Scaler.


Yes, your “double vision” graphics is a perfect description of my point #1. I’m also using VST3 but on Windows 10.

I don’t get any hissing though. I’m just stuck with felt piano sounds whatever I select.

1 Like

Seeing the same here as others.

Studio One v6.6 features the very latest updated VST SDK and is now exposing a number of existing plugins out there that either do not conform OR need some TLC - OR Studio One v6.6 needs some TLC as well.

Presonus is aware of these developments but it couldn’t hurt to have Davide and/or Plugin Boutique make a few calls.


Yeah, I was, and I had to revert to VST2 version, because the S1 6.6 update messed up Scaler 2. And it’s a known problem. Every S1 user who has scaler has this issue, and there’s a separate discussion here about it.

It’s also not only a Scaler problem. Some other VST3 plugins have issues too.

Apparently reverting to Scaler 2.7.3 VST3 version will work if one doesn’t want to keep using VST2.

Confirmed. You can’t even access the settings, the gui is not responding with certain actions also. Why is Plugin boutique only showing version 2.8.1 in my account when 2.8.2 was (available November 7th, 2023) acording to your update page.

Windows 11 Latest, Studio One Latest version.

Our devs are looking into this and will notify PIB too. Not sure what has happened in the update to Studio One v6.6. Strange that reverting back to Scaler 2.7.3 works. Can you confirm that @Ananmusatili ?

I recently updated Studio One from 6.5 to 6.6 so it could have something to do with that, but I can’t open up settings in Scaler 2. It loads and I can perform to another instrument, but no sound on the internal Scaler 2.

I reverted back to Studio One 6.5, so no problem. Lesson re-learned: I never download a software update for at least a few weeks, to circumvent such problems, but this time I rushed headlong.

If you’re a Studio One+ member, this is easy. You go to your “” page, login, navigate to the page that for your recording software - i.e., Studio One - and in small type it’ll offer you “previous versions.” You can download 6.5.2. I’ve kept 6.6 adjacent for when the kinks get ironed out.


Unfortunately I can’t confirm it as I didn’t revert myself. That is hearsay from VI-Control forum.

As predicted, Presonus are keen to blame the plugins rather than their changes.
They have not yet commented directly on Scaler 2 or replied to my support ticket but forum user “flow”,(QA Specialist, PreSonus Software) said this about Uhe Diva, another plugin that does not work in Studio One V6.6:

…we made changes conform to the VST3 specifications which should be backwards compatible. However, such changes may also show flaws in the plug-ins themselves, such as with Diva. We are looking into this, we are well aware of the issue.
Usually, if pretty much every other plug-in works, it most likely is the plug-in which has either a bug or a workaround implementation to run with a certain DAW. Rarely, it may actually show a bug in the host.

Heads Up!!
Apparently the latest Studio One update (v6.6) breaks Scaler 2 interface…
I will be contacting Presonus but I wanted to stop anybody else from upgrading…
(Windows 11)

Yeah, there’s another thread in this topic, but “don’t” is the correct guidance for now. If you did (as I did) go back to your Presonus account and redownload Studio One 6.5.2. That solved my problem.

1 Like

Yep - it breaks it real good. You’re basically left with Scaler 2 in demo mode and no way to update it or verify keys within the plugin. This is poor form by PreSonus and not thought out - additionally the S1 6.6 upgrade seems to be primarily around pushing users onto the Hybrid or full subscription models.

I’m not liking this direction and any number of Gregors or Joes aren’t going to save Studio One as a competitive DAW if this sh!t keeps going.

i’m still using Cakewalk by Bandlab and awaiting the new Sonar product to be fully baked. :wink: i’ve been tempted to buy SO pro but $$$ and not hearing great stuff - a few features maybe not in CbB but honestly, not $600 worth (for me anyways).