Studio One 6.6 problem with Scaler

so far Presonus says just to install old version in parallel… not the answer I want to hear…
… I removed the update and installed the old one…

Fossile, I’ve tried various other DAWs and, just being an occasional user, I found SO so much easier to get results without being an expert…
That being said, if you work with your DAW constantly, (and get the hang of it), there may be better solutions out there…

same lie everyone doing the new “we named the folder something.vst3 and now things break but it’s been in the spec and so it’s your app, or its your plugin, or hey, maybe it’s just stoopid to give folder extensions that are the same as executable programs… durrr…”

1 Like

I’m glad I saw this thread !! I’m actually two versions behind on Studio One (6.5.1) and 1 behind on Scaler, and I was just thinking this morning I should bring everything up to date.

Think I’ll pass on that. :slight_smile:

Our wonderful developers have found a fix and proactively pushed out a test build which I have sent to most people in this thread. Once we hear back that it resolves the issue for Studio One 6.6 users we will bake in the code and release it as part of Scaler 2.9

1 Like

I am happy to report that this new version of Scaler works with the SO 6.6 upgrade!
Thanks to the responsive team at Scaler!!

Note: I only tested the MIDI functions as I am not familiar with the audio functionality but I suspect it will also work fine.

Thanks again!

Hey Davide,

I’m in this thread but didn’t get sent this test build. Could you please send out to me as I’m in the middle of something time-critical with Scaler 2 quite deep in it. Thanks mate.

Would you mind sending me the fix too? Thanks.

Posted to wrong subject. Deleted.

Hi Davide,

It appears that the link is for a Windows installation of Scaler. I am on a Mac (Macbook Pro M1). Is there a different link for the MacOS version of the installer? Would like to test this and make sure that it works.

Thanks again,




Have posted Mac version in the message thread

And have added PC and Mac installers too.
Would someone please confirm Mac version fixes the Studio One 6.6 issue?

Hey, I’ve searched this topic throughout, but I can’t see the links. Where do I get the fix for PC version?

Hi Davide,

I can confirm that the Mac version fixes the Studio One 6.6 issues. Menu’s now work, no more “double vision” in Section C and no more hissing sound from being in demo mode. The updated ScalerAudio works as well. Thanks to your team for fixing this so quickly. Love Scaler and can’t wait for 2.9 to be released!



Hi, where do I find the links?

VST 3 still freezes when dragging on my system. AU and VST 2 work.

The V2.9 did not fix the problem for me. It’s still the same as in my first post.
VST3, Windows 10, Studio One V6.6.

Appreciate your efforts Davide and Team,

No dice on S1 6.6 operating on Win 11. Same behaviour after the beta upgrade. I’m just a bit concerned that when V2.9 drops there’ll be the same issues. Thanks Presonus - nice screw up.

Not sure how Hairy Mug got his working OK, but it seems that may be an exception.

Need to tread carefully on the “presonus” comments here.

In conversations with several sources over there - they have completed an extensive code review to determine if v6.6 is actually causing any of these issues (and NOT just with Scaler) and they cannot find anything out of the ordinary (yet).

This is not to say that v6.6 is 100% in the clear either. But this new “beta” works fine here on Win 10. And I trust the Scaler DEVS know exactly what is going on with their own code.

They cannot however - overcome every possible Windows configuration out there.

FWIW: I am seeing some other odd posts appearing now (in other forums) with S1 v6.6 - but ONLY on Windows 11. Things that are not related to Scaler specifically but stranger things like the update will not even install on some Windows 11 users workstations etc.

Clearly more work needs to be done here - but not sure it has anything to do with Scaler.


Thanks SonicMojo,

I’ll pay that due regard.

I’ll reserve judgement. I’m leaning towards Scaler not being the culprit on the reports coming in, and quite frankly, I’d prefer S1 wasn’t the culprit either as I’m a major convert to it. Win 11… well, there’s history there with things breaking.

Thank you for your insights. Let’s wait and see. VST2 will have to do for now. It’s all rather a first world problem tbh.