Sustain Pedal Sticking on When Perform is Active

When I hit a note or chord twice or more while my sustain pedal is pressed, then release the pedal, the note or chord sticks indefinitely. I have to press the midi panic button or click the chord(s) to stop the sustain. This happens only when any of the perform options are enabled, whether the notes/chords are triggered by keyboard or by clicking on them in the plugin.

If I only press them just once before releasing the sustain pedal they stop as expected. I’ve seen people mention sustain issues in Scaler 1, and you have mentioned the ‘Allow multi-trigger’ option, but I can’t seem to find this option in Scaler 2 to try as a troubleshooting step, if it’s even there.

Scaler 2.06 in Logic 10.5.

1 Like

I noticed this too! I have posted also about this, please fix this bug!

Btw I only have this with falcon up until now

I have to confirm that. It’s a bug.

Win 10 / Cubase 10.5 Pro / Scaler 2.09 (VST3) -> Triggering Spectrasonics Omnisphere/Keyscape or KONTAKT.
(Scalers keylock is active) Result: Some endless notes. Not usable.

By the way: Why are the recorded notes extended if Scaler gets a CC 64 (sustain pedal)? The CC64 data should be forwarded 1:1 to the Sampler or Synth. At least this should be an option/default option.

Now I can’t use Scaler the way I would like to use it.

Can you patch the “endless bug” and enable pass through of CC64-data please? :eyes:

1 Like

I co sign on this situation. I have it too and it should be fixed ASAP. It’s not a small bug, it makes it literally unusable for me!

1 Like

I spend some more time in this issue. It happens with VST2, too.

In VST2, the CC64 event is also not sent to the VST’s MIDI-out. The notes lengthen with CC64 and then get stuck until I stop recording. (Scalers key lock enabled)

Please fix that! I would like to use Scaler as an important part of a complex project template, which is why the performance modes were particularly important to me. I would love to donate some coffee if you get this sorted ;-).

If you need more information on how to reproduce, let me know. But I think it’s relatively clear and quick to do. (Multiple, big, overlaying chords while sustained with CC64/pedal). If I monitor the MIDI-data “Note off” is not send.

I’d like to buy you a couple of coffees if you guys fix this. :grin:

1 Like

Hi @mzett

thanks for the additional info, definitely sounds like something is wrong if even the VST2 doesn’t pass the message through.

We will have a look and try to get this sorted soon.

2 Likes

Some more input:

If I send “Note On - C1 - 127” then release the key (resulting in “Note On - C1 - 0”)
Scaler 2.1 transforms it to “Note On - C1 - 127” and “Note Off- C1 - 0”.

If you use the sustain pedal, this is what reaches Scalers Midi input:

Pressing C1 ->“Note On - C1 - 127”
Using Sustain pedal -> “Controller 64 - 127”
Release the key C1 “Note On - C1 - 0”
Release Sustain pedal -> “Controller 64 0”

But after processing within Scaler Scalers Midi out will be:
“Note On - C1 - 127”
(Sustain now holds/lengthen the note(s), but no CC64 is in the midi out anymore.)
After releasing the pedal:
“Note Off- C1 - 0” is send.

It should be, that only the key is altered or the mapped chord is played etc.
CC64 should bei passed thru 1:1. (Every CC has to - to work around this issues is pretty complex)

And if you send Note on 127, then Note on 0 for one key press- and release cycle - then it’ shouldn’t make “note on / note off” out of it. I think there may be a connection to how CC64 is currently processed. Maybe that’s a minor issue, but I think it’s best if Scaler only intervenes where it is absolutely necessary. This prevents potential causes of errors. At first one expects something else to be output …

I’m glad to beta-test again if it helps.

I hope what I am described is understandable :slight_smile:
Thank you!

I have the sustain issue as well extremely frustraiting

Hi @robinoz and @mzett

Scaler 2.2 will add a new setting for the sustain messages to be either consumed by Scaler or passed-through for your external sound library to deal with it on its own.

Cheers,
Ed

1 Like

Same problem - not solved: 10.15.7 - Scaler 2.2. Need help. Thanks