The performance difference when auditioning a progression and what it sounds like when you drag the MIDI

I’m new to Scaler 2 and just loving it. I’ve made a progression I like. I’m auditioning it, in Felt piano, thru the plug in. I have both Humanize options on. It’s 1/8 arpeggio going up. Very simple progression, 118 bpm. In other words, it’s not a crazy complicated thing. My question is: while listening to the progression played by Scaler, I’m hearing all kinds of performance variations that I really like. They are subtle and they vary. But when I drag this progression to Ableton, it sounds much more stilted and robotic. And the imperfections are not there. I even tried Capture Midi and played the progression that way, hoping it would retain some of the quirks but no luck. It almost sounds like the sustain pedal is on when Scaler is playing directly, but not when it plays back the MIDI in the track.
Is there a way to really capture what I’m hearing directly?
thanks much!

Hi @Bray

Welcome to the forum.
If you are playing the captured Midi performance back through Scaler make sure that any performance or binding that you had on is now switched off or it will sound different. So this means you need to switch off any performances, humanization or chord bindings that you had on to create the performance.
With all of these switched off your Midi capture or dragged Midi will sound identical playing back through Scaler.

Hope this helps

I think the problem is more on the Ableton side. He says that he drag the captured midi there, so probably the playback is managed by Ableton. Could it have something to do with Ableton having some settings turned on, like some sort of quantization or something in that sphere?

I use Scaler in Ableton 10 and 11 on Mac OS 10.13.6 as well as Cubase 11 and I have no issues with the captured MIDI sounding the same as the performance. Do you have quantize set to a high amount? Try turning quantize off. Is the MIDI playing an external instrument or Scalers instrument. If it’s playing Scaler then you need to turn binding OFF and performance OFF after export so it’s not triggering twice.
Anyway you can tell us what your computer setup is?

Hi @jamieh, @LostInFoundation and James,

Thank you very much for all your help. So the issue was with not disabling Performance mode. Once I did that it resolved almost all the difference. There are still some unique notes that are hit when playing thru the Scaler plug that are not in the MIDI drag, but I can almost recreate them manually by adding some MIDI notes by hand.
I’m using Ableton 11, Mac Big Sur OS 11. Quantizing was set to off. And I am playing Scaler’s Felt instrument.
Thanks again very much!

I’ve never experienced this. Which settings?