There is no audio nor sound,

I tried to play a sound in Scaler 2 but could not play a single could not play a single sound or chord. Checked to see if I can play other instruments, and could. Just Scaler I am unable to play a sound. How can I fix this?.

Can you supply us with more information. What is your computer OS, what DAW are you using, are you trying to play Scalers internal sounds or external VST sounds? Do you have Bindings turn on?
Do you have a chord pattern in any sections?
You need chord patterns to play sounds. If you click on the play arrow on the lower left, Scaler will play the chords in Section C in sequence. If you Right Click on the Play arrow Scaler will sync to your DAW.

If you click on the Scaler logo on the upper left you’ll have access to the Manual and the links for video tutorials.

OK I tried binding the keys but did not get any sound. I am using windows 10 home edition and using Mixcraft 9 for the DAW. Tried to bind this to B and C but was not successful. A is unable to select. Hope this helps.

Have you watched this video?

I am Sorry but this did not help. It seems to me that the notes are appearing in the midi section.

Can you take a screen shot of Scaler open in you DAW and post it here? It might help.

I am not sure I can follow. Let’s start simple… when you just startup Scaler, with no special settings…

And you click on the Scaler keyboard at C3, does it make a sound that resembles the Felt Piano?

Here are a few pics Hope these will help. Nothing abnormal about the front screen. The only thing that I notice is when you press a key the notes don’t show up.

This could be it just want confirmation.

See nothing look abnormal here just when you press a key, the notes do not show up.

When you play a chord or a note into Scaler do the keys turn blue?

OK, I don’t know your DAW, but I found its User Manual. Is your track armed (basic thing, isn’t it, but I forget sometimes)? According to the manual, it should be red:

In your case, it looks like your track is not armed (or “arm” is disabled).


1 Like

Still won’t work,. Tried arming it but no go

If you click on the piano keys do you hear anything?

OK, let’s try basic things.

  1. On the same track, replace Scaler with any other instrument VST and arm the track. Press any key on your keyboard. Does this work?
  2. If not, be sure that your track is MIDI, not Audio track.
  3. Check the output, probably to Master, as well as output level of this track., If below 0, set it higher.
  4. Retry 1)
  5. If still no sound, than create a new MIDI track with “Scaler 2” (not Scaler 2 Audio) as instrument and arm it. Be sure that the instrument is not OFF in Scaler.
    Oh, yes, do you see the instruments in the list as below (where I see Felt Piano)? If not, did you install Scaler’s sounds? If you did not, just add any instrument you have after created a new MIDI track and retry.

Do not bind any section. Just press any key on Scaler’s keyboard.
If this works, set a scale with “Scale” button and enjoy.

10% free disk space is a low limit recommended for Windows, but not a mandatory. At this level, everything should still work, so this is not an issue.

Tried all of the no go

I would try a reinstall and make sure the location of the instrument files is where Scaler is looking for it.
If there is no audio clicking on a key then there may be no samples installed.

You could also try running Scaler “standalone” in Nanohost, to rule out DAW complications.
NanoHost freeware - minimalist VST host (