Time Signatures and FL Studio - Scaler plays half the time when I drag the midi

I have set the time signature to 6/8 in FL Studio with a 112 tempo and on Scaler the settings that fit the tempo are as per attached screen. However, when I drag the midi into FL Studio, Scaler has half the time leading and this causes issues with some melodies lost. Please advise.

Did you set the global beats to 6? Click on the gear on the upper left to get to preferences –

I would then leave the duration setting to 1 and that would translate to 6/8
If you drag and drop in Cubase everything is fine but if you drag and drop in Ableton Live you’ll need to change the clip setting to 6/8 since the clip defaults to 4/4. I don’t know what FL Studio does with the clip timing.


@jamieh Thank you very much :slight_smile:

This has worked. Yesterday was my very first time working on Scaler and you’ve solved my problem.

1 Like

Ah, I’m hoping you solved my problem - Ableton in 6/8, playing Scaler to trigger chords (playing manually in time, not letting Scaler play them) and then recording, dragging the clip and it’s out of time. I was looking everywhere for a time sig setting but didn’t think of setting beats to 6! Thanks

EDIT, YES SOLVED thanks so much, it was driving me crazy. I’d thought of forcing the ableton clip to 6/8 but that was not enough

EDIT 2 - I spoke too soon. When I play the chords in the set in time, set record MIDI in Scaler, drag and drop in Ableton and then change the clip to 6/8 it’s still out of time. The only way I could get around this was to leave Scaler sending midi to another instrument and record the trigger notes only for the chords. Normally I prefer to record the midi, drag to a new instrument and then I remove Scaler once the song structure is there. Not really sure how else to fix this.