Time Signatures and FL Studio - Scaler plays half the time when I drag the midi

I have set the time signature to 6/8 in FL Studio with a 112 tempo and on Scaler the settings that fit the tempo are as per attached screen. However, when I drag the midi into FL Studio, Scaler has half the time leading and this causes issues with some melodies lost. Please advise.

Did you set the global beats to 6? Click on the gear on the upper left to get to preferences –


I would then leave the duration setting to 1 and that would translate to 6/8
If you drag and drop in Cubase everything is fine but if you drag and drop in Ableton Live you’ll need to change the clip setting to 6/8 since the clip defaults to 4/4. I don’t know what FL Studio does with the clip timing.

1 Like

@jamieh Thank you very much :slight_smile:

This has worked. Yesterday was my very first time working on Scaler and you’ve solved my problem.

1 Like