UI Scaling Issue - Windows

Users have reported an issue where the window of Scaler has an incorrect size.

This seems to affect differently some versions of Windows 10.
DAWs can have their own settings to enable or disable the DPI awareness. This makes it hard to troubleshoot as there are many possible combinations of settings.

I have tested VST2, VST3, 32 and 64bit versions in multiple DAWs using (Win 10 - v1803 - single HiDPI 5K screen) and it works properly in Reaper 32 and x64 , Studio One 3, Bitwig Studio 2.4 , Ableton Live , FL Studio (non bridged) regardless of the settings in Windows (scaled percentage, “fix blurry apps automatically”…).

We suggest to:

  • Update Windows to get the latest patch from Microsoft (the update from April 2018 fixes a number of these issues)
  • Enable/Disable the HiDPI support in your DAW and check for improvement.
  • Enable/Disable the scaling in Windows and check for improvement.
  • Try to unplug any external monitor and see if it fixes the issue.

Here are some more info on how to deal with those issue in windows: https://windowsreport.com/fix-hidpi-issues-windows-10/

If you still encounter the issue after trying those different things, could you please communicate the following info to help us accelerate the fix:

  • Version of Windows (with the patch version which can be found in Settings > System > About) for example: “Win 10 - 1803”
  • Architecture of DAW (64/32bit)
  • Architecture of the plugin used (64/32bit)
  • VST version tested (VST 2/3)
  • Scaling settings in Windows (Scaling value in percentage and if “fix blurry apps automatically” is enabled)
  • Number of screens connected to the computer with resolution and DPI (if known)

Thanks,
Ed

Hi,
the issue occurs here:

Win10 1809, Scaling 125% (3840x1440, GTX970)
Cubase 10 64bit HiDPI=on
VST2/3

Scaler is only partly visible inside the plugin window.
Do you plan a fix (because I just bought Scaler and now not able to use it, sigh)

Cheers

Hi @ppppp

Thanks for the info, we are working on a fix which will be released in January.

Sorry about the inconvenience,
Ed

I just tried Scaler with Notion 6 and the HiDPI scaling is broken. The interface is tiny and unusable.

Windows 10 1909, scaling usually set to 150% (but I also tried 200%), 64 bit for both Notion and Scaler. Usually with 2nd dummy “screen” for HDMI sound output but disabling it and only using a single screen doesn’t make a difference, neither does the Windows option to fix blurry apps.

If I enable “Legacy DPI Scaling” in Notion (i.e. disabling HiDPI support and letting Windows take care of it), both Notion and Scaler are scaled up by Windows and therefore look blurry (which, in the case of Scaler’s low-contrast UI - particularly in light mode - is not much more usable than the tiny, unscaled version).

Update: After some more experimentation I found a workaround. In the properties of the Notion shortcut, go to “Compatibility -> Change high DPI settings”, enable “High DPI scaling override” and set it to “Application”. While Notion already used this scaling mode, this forces plugins to also do their own scaling.

There’s one remaining issue: The Scaler window is not resizable when opened from Notion. The 2 resize handles are simply missing. I gave it a quick try in Dorico and it does work fine there. (I’m not sure if that’s specific to Scaler or affects all plugins; I don’t have any other plugins that are supposed to be resizable)