UI Scaling Issue - Windows

Users have reported an issue where the window of Scaler has an incorrect size.

This seems to affect differently some versions of Windows 10.
DAWs can have their own settings to enable or disable the DPI awareness. This makes it hard to troubleshoot as there are many possible combinations of settings.

I have tested VST2, VST3, 32 and 64bit versions in multiple DAWs using (Win 10 - v1803 - single HiDPI 5K screen) and it works properly in Reaper 32 and x64 , Studio One 3, Bitwig Studio 2.4 , Ableton Live , FL Studio (non bridged) regardless of the settings in Windows (scaled percentage, “fix blurry apps automatically”…).

We suggest to:

  • Update Windows to get the latest patch from Microsoft (the update from April 2018 fixes a number of these issues)
  • Enable/Disable the HiDPI support in your DAW and check for improvement.
  • Enable/Disable the scaling in Windows and check for improvement.
  • Try to unplug any external monitor and see if it fixes the issue.

Here are some more info on how to deal with those issue in windows: https://windowsreport.com/fix-hidpi-issues-windows-10/

If you still encounter the issue after trying those different things, could you please communicate the following info to help us accelerate the fix:

  • Version of Windows (with the patch version which can be found in Settings > System > About) for example: “Win 10 - 1803”
  • Architecture of DAW (64/32bit)
  • Architecture of the plugin used (64/32bit)
  • VST version tested (VST 2/3)
  • Scaling settings in Windows (Scaling value in percentage and if “fix blurry apps automatically” is enabled)
  • Number of screens connected to the computer with resolution and DPI (if known)


the issue occurs here:

Win10 1809, Scaling 125% (3840x1440, GTX970)
Cubase 10 64bit HiDPI=on

Scaler is only partly visible inside the plugin window.
Do you plan a fix (because I just bought Scaler and now not able to use it, sigh)


Hi @ppppp

Thanks for the info, we are working on a fix which will be released in January.

Sorry about the inconvenience,

I just tried Scaler with Notion 6 and the HiDPI scaling is broken. The interface is tiny and unusable.

Windows 10 1909, scaling usually set to 150% (but I also tried 200%), 64 bit for both Notion and Scaler. Usually with 2nd dummy “screen” for HDMI sound output but disabling it and only using a single screen doesn’t make a difference, neither does the Windows option to fix blurry apps.

If I enable “Legacy DPI Scaling” in Notion (i.e. disabling HiDPI support and letting Windows take care of it), both Notion and Scaler are scaled up by Windows and therefore look blurry (which, in the case of Scaler’s low-contrast UI - particularly in light mode - is not much more usable than the tiny, unscaled version).

Update: After some more experimentation I found a workaround. In the properties of the Notion shortcut, go to “Compatibility -> Change high DPI settings”, enable “High DPI scaling override” and set it to “Application”. While Notion already used this scaling mode, this forces plugins to also do their own scaling.


There’s one remaining issue: The Scaler window is not resizable when opened from Notion. The 2 resize handles are simply missing. I gave it a quick try in Dorico and it does work fine there. (I’m not sure if that’s specific to Scaler or affects all plugins; I don’t have any other plugins that are supposed to be resizable)

I have this issue also. Same screen size.
For now, I reduce the windows 10 screen to 100%
This sux but…Scaler2 can function then.

Tried those changed settings, but no luck.
Win 10 Pro 1803
Ableton Live 10.1 64 bit
Scaler 2, 64 bit both VST2 and VST3
Both screens are 2560 x 1440 Scaling 225%
Scaler fills about 4/5 of the plugin window.
This seems to be a longer existing issue.

Hi @Stormy
could you have a look at this help page from Ableton:

@supertux what DAW do you use ?

Hi @luapmartin Paul,
I have already tried that, but it makes no difference.
Exactly the same presentation.

I use Bitwig Studio 3

4k monitor, I use Windows LTSC, updated. Scaler 2 scales wrong LoL.
Cubase 10.0.60 HDPI active, windows scaling 150%

It seems scaler 1 behaves OK enough, but scaler 2 clicking on f.i. artist looks OK,
but as soon as you release the mouse, the RELOADED font letters are useless; too small.

@szeiger already posted this fix, but I had to “discover” it for myself. Fixed Bitwig for me with Scaler and a couple other plugins.


Feb. 11, 2023
Windows 11 Home 64-bit Version: 22621.1105
Screen resolution: 1920 x 1080
Scaling setting: 150%
DAW: Waveform 12 64-bit
Scaler 2.7.2 64-bit
VST3 tested
One screen

Scaler 2’s UI is scaled to approximately 2/3 horizontal and vertical dimensions of the window, though the cursor location for clicks is fully scaled, which made it nearly impossible to register the program. I succeeded, but the problem persists, making Scaler 2 unusable, and I just bought it.

Hi @carllexicon

UI scaling is usually handled by the DAW, check in Waveform if there is a setting either in the preferences or on the plugin instance to manage this.

You would be looking for something about “DPI Awareness” or “UI Scaling” which should either force the plugin to be scaled properly or disable the scaling of the plugin UI.

1 Like

I found “DPI awareness” in the plugin instance and enabled it. Now the scaling is way too big. An earlier version Of Scalar 2 (version 2.5) used to work fine. Do you have any further suggestions? Thank you.

(It was on a different computer. With my new computer the other plugin UIs are scaled fine.)

I fixed it. I had applied the “Override high DPI scaling behavior” fix above my post previously. I turned that off and now with the “DPI awareness” enabled, it works perfectly. Thank you for your advice, which worked.

1 Like

Running Bitwig with 4k monitor and 150% Windows-scaling. BluesCats setting did it for me, thanks @BluesCat !

I have to correct that…

The Scalerwindow worked fine with this but then Arturia och Izotope plugins got the problem instead :frowning:

I have now disabled BluesCats setting and have instead inactivated the setting within Bitwig called “Plug-in Interface Scaling” and they seem now to all work fine.

I’m using Studio One Professional on MacOS ARM 64.

I’ve noticed that when you scale the size of the UI to a smaller size in Scaler 2.9 AU, It does not scale to the frame.