Voice grouping not working on M1(Rosetta), Scaler 2.7.2

I’m having an all too familiar problem very similar to my current thread. This time around when I bind B in any scale the Voice grouping octave function does not work correctly. This can’t be a coincidence. What am I missing here? This seems simple enough. Here are some Gifs of the problem.

  1. Octave 4 / Bind B / Voice Grouping turned ON
  2. Octave 4 / Bind B / Voice Grouping turned OFF

Scaler 2 Voice Grouping     Octave 4 / Bind B / Voice Grouping turned ON

Scaler 2 Voice Grouping 2       Octave 4  / Bind B / Voice Grouping turned OFF

Thanks for supplying those gifs, what am I missing here @AJB ? Looks to me to be working as expected. Voice Grouping overrides everything including octave shifts, semitones etc. It needs to to allow the full potential spread of multiple chords etc. You can always design your own voice grouping profile and extract it and then apply to your own chords if you are looking for things in a higher range. Several posts of mine and manual explains this process well. Hope that helps.

Thank you for reaching out @davide. So, it is intended to work this way? In the first pic, the F major chord should be in the 4th octave. It makes no sense that it doesn’t follow such a basic parameter. I click the octave button and it changes no matter the setting. If I use the dynamic voice grouping all that’s added is the bass root note. That can easily work without disabling the octave function.

I have been complaining about this because I am a heavy Scaler user. Also, because most other functions keep me focused on my creativity. There are too many steps in order to use voice grouping and editing the C patterns. This throws me off completely because now I will have to use Piano roll to draw in what I want for each chord that I play to mimic the voice grouping. It sounds easier than what you are suggesting with extracting etc.

Is there a video you made that teaches specifically how to use the voice groupings? I watched most of them but maybe you have a better memory because you were there.

Cheers and thanks for listening!

BTW This is my favorite plugin for composition!

After re-watching many, many videos, I found enough workarounds to my original issues. It takes patience and time, but Scaler seems flexible enough to find similar solutions to most issues that come up. I’m finally able to move on and compose in peace.

The solution: Rewatch a bunch of videos and practice. :stuck_out_tongue_winking_eye: :innocent:

1 Like