251 and Tritone Sets in Major Keys

I have created a series of sets of major key 2-5-1 sequences and 2-5-1 sequences with tritone substitutions based on 7th chords. Each chord consists of a root, 3rd and 7th, i.e there is no 5th in the chord.

The challenge for me is that because there is no 5th Scaler seems to have named man of the chords with an enharmonic chord name. For example on the C major set the V chord which is a Gm7(no5) is called Fsus2(b5)/G.I beleive these are enharmonic but it is a bit confusing.

Here are the sets I have created:

A Tritone.xml (675 Bytes)
Ab Tritone.xml (675 Bytes)
B Tritone.xml (675 Bytes)
Bb Tritone.xml (675 Bytes)
C Tritone.xml (675 Bytes)
D Trirone.xml (675 Bytes)
Db Tritone.xml (675 Bytes)
E Tritone.xml (675 Bytes)
Eb Tritone.xml (675 Bytes)
F Tritone.xml (675 Bytes)
G Tritone.xml (675 Bytes)
Gb Tritone.xml (675 Bytes)

I think they are correct, but please let me know if there are any errors.

Hope you find them interesting for a bit of colour in your compositions.

1 Like

Hello, Ed66
I’ve downloaded them and put them in my set folder, but I couldn’t open any of the sets you submitted. There must be some problem.
Maybe someone else could try it, please. To know if it is a problem with my configuration or if it is a general problem

No, I can’t load them either…

1 Like

Hello guys,

Sorry about this I don’t understand what the error is. I created the sets by saving the individual patterns from Scaler. I am using Scaler 2.6.0 in Ableton Live 11 on a Windows 10 PC.

I’ve just downloaded all the sets and opened them in Scaler with no problem.

To do this I

  • Created a folde in C:\Users\Public\Documents\Plugin Boutique\Scaler2\Sets

  • Downloaded the sets, then

  • Copied them into the foldeer

  • I then opened Scaler and refreshed the user list.

I don’t know if I’ve missed a step in publishing them or used the wrong process, but any advice would be helpful.

Update

I’ve just tried importing a chord set rather than using the process above and it appeared to not work. However, when I refreshed the User list the chord set appeared and I could open it., so help!

A;so I have just tried this using Scaler in Cakewlak and again no problem; so I don’t know what the issu is

Scaler 2.6 is already out? That might splain the compatibility issues of the saved set files.

Sorry I meant 2.5.0 . I do NOT have 2.6.0 as I am not part of the dev team .

Could I ask a favour, would you please create and save a chord set on your system and then using a text editor compare the xml of your chord set with mine? Or if you can create achord set and send it to me I will also make the comparison.

That might help identify the issue

I have included the xml from A Tritone.xml below

<?xml version="1.0" encoding="UTF-8"?>

<CHORDSET version="2" uuid="20fa15c3-31e9-43a2-b25a-7d6b1d984fce">
  <CHORD>
    <NOTE MIDI="59"/>
    <NOTE MIDI="69"/>
    <NOTE MIDI="74"/>
  </CHORD>
  <CHORD>
    <NOTE MIDI="64"/>
    <NOTE MIDI="68"/>
    <NOTE MIDI="74"/>
  </CHORD>
  <CHORD>
    <NOTE MIDI="57"/>
    <NOTE MIDI="68"/>
    <NOTE MIDI="73"/>
  </CHORD>
  <CHORD>
    <NOTE MIDI="59"/>
    <NOTE MIDI="69"/>
    <NOTE MIDI="74"/>
  </CHORD>
  <CHORD>
    <NOTE MIDI="58"/>
    <NOTE MIDI="68"/>
    <NOTE MIDI="74"/>
  </CHORD>
  <CHORD>
    <NOTE MIDI="57"/>
    <NOTE MIDI="68"/>
    <NOTE MIDI="73"/>
  </CHORD>
</CHORDSET>

Many thanks

I already compared the files you sent with the one I recently sent, and certainly (opening in windows notepad, they look different
I won’t be on PC until tonight, but I’ll check later.
And, whatever the problem, first of all thanks for sharing your experiences, Ed66

jjfagot

Can you tell me what the differences were, please, as it may help identify the issue?

I am confused because I made no edits on the file that was saved other than to edit the file name, which should make no difference to the file contents.

As I write this I have had a thought from left field: Is there some sought of integrity check between the uuid value and the file namei

I won’t be able to spend much time on this today, but I may be able to spend a bit more time tomorrow, but I have resaved the chord sets using the export chord set command. These are the new sets:

A_Flat_Tritone_Substitution.xml (676 Bytes)
A_Tritone_Substitution.xml (676 Bytes)
B_Flat_Tritone_Substitution.xml (676 Bytes)
B_Tritone_Substitution.xml (676 Bytes)
C_Sharp_Tritone_Substitution.xml (676 Bytes)
C_Tritone_Substitution.xml (676 Bytes)
D_Tritone_Substitution.xml (676 Bytes)
E_Flat_Tritone_Substitution.xml (676 Bytes)
E_Tritone_Substitution.xml (676 Bytes)
F_Tritone_Substitution.xml (676 Bytes)
G_Flat_Tritone_Substitution.xml (676 Bytes)
G_Tritone_Substitution.xml (676 Bytes)

Apart from the uuid values I cannot see any difference between these and the original files I uploaded, except these are 1 byte larger.

I have successfully downloaded the A_Flat_Tritone_Substitution chord set and implrted it useing the Import Chordset command on Scaler. I then refreshed the User list and opened the chord set with no issues.

I would be grateful if someone could try it with one of these new chord sets and let me know the results.

Hello. I’ve tried opening the new xml files, and none of them work for me either.
I have opened one of the files with notepad (Windows) and compared it with one of mine (which I attach) and clearly its content is different

Tritone Example.xml (46.3 KB)

The upper files is a ‘chordset’ and the lower one a ‘state save’. The two are quite different. Both can be fed back into Scaler.

I did pen a post on the latter at

When you do a save, you can save the full session (equivalent to right clicking on the logo and then ‘export state’) or just the chord set, which is a sub-set of the former with a slightly different structure.

It’s maybe a bug. I Just did the following

1 Clear state
2 Load a song
3 Drag to C
4 Save chordset and session
5 Clear state
6 Import state file … ok
7 Clear state
8 Go to user and import file - nothing happens.
9 Clear state
10 Go to user and import a chordset from last year - nothing happens.

Hard to see how three different people can observe the same anomalous behaviour and it not have been noted before. Odd

1 Like

Hi Guys

I am going to raise this issue of our difficulties as a bug with support.

In the meantime, I have saved one set of chords, in the key of A, using the Export State command.

If you are able to import this, then I will upload the other 11 sets
A_Tritone_Substitution_State.xml (10.7 KB)

It works!
Thank you Ed66

I’ll prepare the other sets and load them later today.

It looks as if this may be an issue with saving annd loading chord sets as opposed to states…

I have now created 12 states, one for each key, to demonstrate tritone substitutions of the 2-5-1 chord sequence. Each state has two patterns: 2-5-1 and the tritone substitution. I hope these work

E_Tritone_Substitution_State.xml (18.2 KB)
E_Flat_Tritone_Substitution_State.xml (18.2 KB)
F_Tritone_Substitution_State.xml (18.2 KB)
G_Tritone_Substitution_State.xml (18.2 KB)
G_Flat_Tritone_Substitution_State.xml (18.2 KB)
D_Tritone_Substitution_State.xml (18.2 KB)
C_Tritone_Substitution_State.xml (18.2 KB)
C_Sharp_Tritone_Substitution_State.xml (18.2 KB)
A_Tritone_Substitution_State.xml (18.3 KB)
A_Flat_Tritone_Substitution_State.xml (18.3 KB)
B_Tritone_Substitution_State.xml (18.2 KB)
B_Flat_Tritone_Substitution_State.xml (18.2 KB)

I hope that these work

2 Likes

Definitely, at least for me, saving as state xml works

OK, good news and lesson learned here

There is one interesting difference between one set of files you posted and others, and that is the second set had a trailing hex nul. The chordsets can end thus
crlf

with 0A 0D (CR/ LF) or as in the C# Tritone set example with a training nul

hex nul
i.e. 0A 0D 00.
I have no idea (a) what different actions generated different formats (computers don’t do random) (b) whether this has any bearing on the chordsets which can’t be read.

I had previous posted recoding that trailing nulls in State files caused a crash in some XML programs which read them.

I’ll experiment more to see if I can do some structured tests and figiure out what is happening.

Later comment Even with the Simplest test on this machine, saving and importing chord sets does not function as documented or expected in this environment, using Scaler both in Live and in Cantabile .
Oddly, session saves are shown but not chord sets, and these can be restored.

I would need to do much more extensive tests noting the exact circumstance in each case. Since state files work, it’s easier to uses those than spend time on something which will no doubt be fixed in 2,6

These work for me on Mac.