Apple Silicon problems

Hi guys,

I have a question: In a YouTube Live Davide said that 2.5 is not really working in Monterey, since the midi was changed by Apple or so.
On PluginBoutique now it says Monterey is supported/compatible - but it is still the same 2.5 Davide was talking about

So just to make sure, is it native now under Apple Silicon and works with Monterey?

Thanks a lot!

Tom

1 Like

I didn’t catch the YouTube stream but I switched to an M1 Studio recently and I’m running into big problems regardless of being native or running under Rosetta - unfortunately the issue has just been made significantly worse by the latest Apple update, which I updated to yesterday. Scaler now seems practically unusable, whereas before it was just very laggy.

Would be great to have a update from @davide on whether a fix is on the way

I’m not on the coding team and it is beyond my remit but I am chatting with seniors at Apple in the background to try and assist all parties. There seems to be a seperate issue to the duplicating tracks / oddness in M1 Monterey machines which works fine under rosetta and we are reliant upon Apple / JUCE developers and our coders which is only a matter of time.
Your issue is a lag issue which only a few users are having. We don’t have those issues on any tested M1 Mac running scaler natively but our dev team are aware so more specifics you can pass on here the better they can problem solve. The fact that you are having issues under Rosetta is worrying. I am keen to hear from any other M1 Studio users as we haven’t had many other reports there.

1 Like

Thanks @davide ! Yes, right now (under Monterey 12.4) I’m finding it easy to crash a vanilla project that only has one or two instances of Scaler.

Happy to assist in whatever way I can (screen recordings, testing things out etc). Happy for someone to contact me directly while I screenshare, and try different options if that helps. I also have two prior versions of Logic available (10.6.3 and 10.7.3) so can test using those if needed.

I seem to remember the days when Mac people looked smugly on PC users having perennial problems with its myriad matrix of mix and match hardware, whilst their Macs were solid as a rock because of the closed architecture and closely controlled updates.

These issues are a bit different because it’s software, but MIDI / audio is pretty bare metal, so I couldn’t resist a (very teeny) and passing half smile at the Apple woes … schadenfreude, as @Bernd might well say …

2 Likes

Actually the M1 Mac is a whole new architecture that brings the iOS and Mac software systems closer together. Scaler running rough on an M1 and it’s optimized OS is not really that surprising. The odd man out is of course that not all users are experiencing these issues. First world problems for life on the edge.

1 Like

so I couldn’t resist a (very teeny) and passing half smile at the Apple woes … schadenfreude

Sorry, I can’t hear what you’re saying right now because I currently have 500 instances of Serum playing simultaneously in Logic. What? No, it’s not the machine’s fans drowning you out … they aren’t even spinning up (does a little dance) :wink:

Haha, yes, thankfully as more people have switched over to Mac, the pool of vocal elite Mac users has been diluted quite a bit.

PS I really did do a test when I got the M1, just for kicks, and really did have over 500 instances of Serum playing simultaneously on this machine without the fans spinning up. Yet I installed Steam and tried to play Obsidian … and the experience was still crappy ¯_(ツ)_/¯

PPS Scaler issue now resolved (ner)