Band Settings Not Retained

I just realized that when I re-open a project that has ScalerEQ (v1.1.1) in it
all the EQ Band settings are lost, BUT the Key selection is retained.

Very repeatable in Reaper v7.15, for example:

  1. Create new project.
  2. Add Scaler EQ to a track and adjust Key, and Band 4.
  3. Save and exit Reaper.
  4. Re-open project and see that Band 4 settings are gone.

Hey @JasonD Can you open a vanilla project and load a fresh instance of Scaler EQ and try again. We can’t replicate your behaviour ( @Tristan - can you try on your Reaper ) So I can only imagine a conflict with the old version. Silly question - have you installed SEQ 1.1 and then restarted your machine?

Hi Davide,

It was very repeatable in a vanilla project, across reboots.
Then I re-installed 11473_Scaler-EQ-1.1.1.exe, and the problem is gone.
This is that same version that was already installed, so that is weird. I will
let you know if it happens again. Thanks for the reply.
Best wishes.

1 Like

Hi @davide

Sorry, this problem still exists for me.

I thought it was fixed by re-installing, but it turns out it is not.
I can create a new project in Reaper and add Scaler EQ to the MASTER track and setting will be
saved with the project. So, at that point it seems to work.

BUT if I add another track to the project then save the project all the Scaler EQ settings are lost.

Any insights on this?
Is there a better place to ask about issues like this?

Hi Jason I have just sent you a PM:

Hi Jason, Tristan has tried to replicate your issue on a very similar setup (with Reaper 7.1.6) and we just can’t. This is a new build which addresses a few other issues. I’m just wondering whether you install it and it somehow magically fixes your issue can you try and let me know?

Same behavior here in Pro Tools 2024.3 - macOS 14.5

Edit: Just re-installed 1.1.1 - same behavior. Scalar does not retain settings.

More details:

When Reaper saves a project the ScalerEQ settings are saved as an encoded block inside
the XML project file. This encoded block represents the state of the plugin.

If I change a band in the ScalerEQ and Save-Project I DO see that the encoded block in the XML
is changed, which suggests that the new ScalerEQ state is being written.

Perhaps what is happening is that when the project is re-opened later ScalerEQ is ignoring
or failing to parse that same state information that is handed back to it from the project.


OK thanks all, I’ve passed all the latest info on to our devs. I’ll let you know when they come back to me with their thoughts. Thanks for persisting, it’s annoying as we can’t replicate but let’s see how we go.

@JasonD @BCProject We cannot reproduce this at all. Can I ask, are you both using Beatport Access by any chance?

Hi Davide,

Not using Beatport here.
It happens for me in Reaper, and another customer saw it in Pro Tools.
I loaded Cakewalk on the same PC for a test and it did not show the problem.
So, it is somewhat DAW specific (at least Reaper and Pro Tools), but not
for everyone. My PC does not use drive C: for the Temp Dir. I mention this because
there was a prior problem, which you fixed, related to that.

It is a show-stopper for me because if I can not recall project settings I cannot
really use it… so, hopefully you find a clue soon.

Not using Beatport here either.
Scalar EQ has not retained its setting across saves for any of the 4 PT sessions I’ve used it in. These are sessions started long before I acquired Scalar EQ, fwiw.

I just added Scaler EQ to another existing session, tuned it to the song, closed, reopened and I’m greeted with a empty/default Scalar EQ window.

This behavior is so consistent and reproducable - surely a fix is coming?

Hey @BCProject Hard to get a fix for something that appears to be user specific. There are thousands of Scaler EQ users and two users reporting having this issue. We’ve devoted much time to try and help but can’t find or reproduce anything.

If you open a vanilla session in a DAW does it retain settings? Have you tried another DAW to eliminate Scaler EQ as the culprit here?

Hi @davide,

I understand it is difficult when you can’t reproduce it.
Do you know what general framework is used (i.e JUCE, etc), or did you grow your own?


Hi @davide,

A few more thoughts…

Working on another DAW is not exactly a way to prove that Scaler EQ is totally OK.
I have over a hundred plugins here that work fine, so there is that to consider.
What makes Scaler EQ different than so many others?
(rhetorical question, I know you don’t have that answer yet :slight_smile:

Logically the plugin is either failing to deliver its config to the DAW for storage,
OR it is failing to accept the config back when a project is reopened.

Since it works for many people we could guess there may be some assumption in the code,
(could be your code, or the framework code) about system configuration that is not true
on every system. Similar to assuming that a USER Dir or TEMP Dir is always on drive (C:)

It would be worth examining both sections of the code, (a) the section that does the Save
settings, and (b) the section that does the Restore settings. Looking here for anything
conditional or anything that relates to system configuration might reveal a clue.

By conditional I mean for example, a plugin that has a “demo mode” that does not allow
saving or loading config. If that plugin had a bug where it falsely THINKS it is in
demo mode at some point then it could cause this problem.

Well as you may have guessed I’m no coder. So it’s my job to work out how and where the devs work on what! They are watching this thread so nothing is lost but using my ignorant brain, I sometimes have problems with plugs when updating them and bespoke not saved settings are lost due to new features or alterations. Happens to me with Scaler EQ, Scaler 2 and other plugs I’m involved with all the time. Hence the reason I asked you, what happens when you open Scaler EQ in a Pro Tools or other DAW vanilla project? If it works as expected then I am sure you can appreciate I’m not going to pull the devs of other projects to spend more time and focus on why one of your sessions won’t recall a Scaler EQ live setting. Particularly when you can just save the EQ preset and your problem is solved. Sure thing, we have 10 people experiencing the same problem then we assume it’s a widespread issue and we spend more time on it. Not being recalcitrant just trying to be transparent. Hope you see it that way too.

Hi @davide,

I’m not sure if you are responding to me, or the Pro Tools guy.
Sounds like you might be feeling a bit overwhelmed.
I provided the info about vanilla projects in Reaper and Cakewalk prior in this thread.

Sorry, I do not see how saving a preset could solve this since later when I open
a project I would not know which preset to re-apply.


I use also Reaper. Same problem me when I tried the demo.
User presets Hahaha No! Can imagine a project 80 tracks and to remember to put back for 20 copies in project every time I open?

Yes, trying to manage presets for this would be impossible for me to keep track of.