Install issues

I have had Scaler 2 for quite some time. It always worked perfectly. I got sick and didn’t access my DAW (Cakewalk) for over a year, until… a week ago. Some critical failure crashed all my VST’s including Scaler. I spent a few day trying to re-install on Cakewalk. With no success, I got Studio One… same issues (on Studio One), as follows:

In the download process (I’m not changing what is included in the installation ie. Vst2, Vst3 etc box)
The next box shows VST2’s path to C: Program Files, Steinberg, Vst plugins (I am not changing this either)…interesting note: I never saw a path for Vst3
The “Sounds” file path goes to a folder on my external drive.

Studio One always shows Scaler in the “File browser” and in the “Plugin Manager” but when I drag it to my project the Scaler plugin opens but is not operational and just black.

Please help if you can this beginner and retired old man is going completely crazy over missing my favorite plugin. Thank you!

Hi @mrngbear and welcome to the forum.

Sorry to hear you are having issues.
Firstly, could you please ensure you are installing the latest version of Scaler form the Plugin Boutique website.

Second to this, if the issue still persists you can try turning off OpenGLRendering in the ScalerSettings. Please see this post for details: Scalar 2 - Black Empty Window with Cakewalk - #7 by Ed1

Let us know how you go

Hi James and thanks, I am blessed to have found this forum.

After countless hours of complete frustration, my issue has been resolved. Turing off the “OpenGLRendering” solved the problem and I now have my favorite plugin back… woohoo!

Thank you very, very much!


You’re most welcome @mrngbear happy creating!