MIDI export into DAW retains sample sound?

Win 10, Reaper

I seem to be missing something: right now when I drag/drop a chord onto a MIDI track in my DAW loaded with a piano plugin from a third-party developer, the MIDI is still using the sample sound from Scaler 2. It’s not triggering the sample sounds from the third-party plugin.

This is odd because, on the same track, previous MIDI items trigger these sample sounds.

So, somehow when I am exporting into my DAW it’s carrying over the sample sound from Scaler? This didn’t used to happen, so I must be forgetting/missing something…

Any help much appreciated!

MIDI does not carry any sound info with so it sounds like you have a routing problem. If it’s not triggering the third party piano then where is the piano sound coming from? Scaler? Can you play your keyboard and trigger the piano? How are the tracks routed?

Hi @Miscreant

Are you dragging the midi onto the Scaler track or the Piano track? I suggest that you should drag the midi onto your Piano Instrument track, and do not route any midi from Scaler to the instrument track. To see how to route Scaler in Reaper you may want to look at Basic Introduction to Multi Out. Although this tutorial is about routing multi output from Scaler it does cover routing in Reaper to trigger instruments on instrument tracks from Reaper.

I suggest you may want to select OFF in Scaler Instrument selection: this will silence Scaler.

Hope this helps

@ed66 He says right here the 3rd party instrument is not playing. That’s why I suspect Scaler is still playing. Without a screen shot or more info it will be hard to sus out.

I agree

and the reason I suggested setting Scaler sounds to OFF is to remove Scaler’s inbuilt sounds from the problem.

As you suggested it probably is

Yep, first thing to try for sure. I’m sure we’ll figure it out when we get more info.