MIDI Routing - FL Studio - VST3

Issue: MIDI routing does not work when using Scaler as a VST3 plugin in FL Studio.

Workaround: Setup MIDI routing using Scaler VST2:

  • Load “Patcher” onto a track.
  • Add Scaler (VST2) into it and the instrument you wish to control.
  • Disconnect the controlled instrument from FL Studio MIDI input and connect it to the MIDI output of Scaler.
  • Open Scaler UI and access FL Studio plugin settings by clicking the cog icon in the top left of the plugin window.
  • Set the output port to something other than the default value.

It should look like this:

1 Like

This is still not working for me I am on FL 12 are there any alternatives?

Are you sure you are using the VST2 version of Scaler and the “Output port” value is set ?

In Patcher, when a MIDI event is received/send, the green link is animated. Is the link between FL Studio and Scaler animated when you play a MIDI note ?

Yes it is and the line is animated but when I play notes inside of scaler it doesn’t just play the notes from my omnisphere. When I play notes from my actual midi keyboard it plays both vsts but when I tap a chord progression within scaler itself it does not respond.

You might need to open the plugin settings of Omnisphere (by clicking the cog icon in the top left of the plugin window) and set the MIDI input port to the same value than the MIDI Output port of Scaler.

I have the same problem in fl studio 20… why is it that under scaler settings midi… there is a midi evnt where its set to input and you cant change it… The patch trick also doesnt work for me… Was really looking forward to use the program to play 3 part plugins live through scaler to record. Now its just giving me a headpain!!!:tired_face:

Hi @mr.lund,

It seems you are using the VST3 version, the VST2 doesn’t have this settings menu.
I just tested in FL Studio 20 and it works fine as long as you make sure to use the VST2 version of Scaler.


1 Like

Yeess Thanks Ed1 that was the case with VST3 vs VST 2… Now it works… Thanks alot and Cheers

I have same problem using VST3 and Audio Unit on FL20. I have not tried VST2 version. Then, I tried two plugins(VST3, AU) on Patcher plugin of FL20. However I did not detect MIDI TURU outputs from Scaler plugins. VST3/AU of Scaler still have bugs on FL20. Anyway I have checked no bugs of Scaler on Logic Pro X. I hope it will be fixed soon.

Hi @kmusiclife,

You are right, for the AU format, it is normal as AUs do not support MIDI routing the same way than VSTs.
For the VST3 is a known issue that will be fixed.

In the meantime, you can use the VST2 version as it works fine in FL Studio.

Is it possible to download VST2.x of Scaler on WEB ? Unfortunately I bought Scaler yesterday. I have got VST3 and Audio Unit except VST2.x. How do I possess it ?


Simply run the installer and check the VST2 option.
If you can’t see it in your DAW, check that your software is configured to look for VST2 plugins.

Thank you for your support. I did it and it is working using VST2.

I create new folder of /Library/Audio/Plug-ins/VST2 then I copied /Library/Audio/Plug-ins/VST/Scaler.vst as /Library/Audio/Plug-ins/VST2/Scaler.vst

A user of FL studio on Mac will definitely do that. now it is working perfect. thank your for your support.

Somebody please help me figure this out… i installed bought and installed scaler today and when i open it, it only opens the VST3 version. However, when i downloaded it it showed that the VST2 version was being installed in my location. How to I open the VST2 version, so I can get this thing to work(meaning routing it through my XPander2 plugin)…

THis is literally killing me… thanks in advance for any help on this

Are you sure FL Studio is configured to see other VST folders ?
In FL Studio go in 'Options > Manage Plugins" look under “Plugin search paths” in the left panel.

You should see something like this, with entries for VST and VST3

Thanks so much for the reply Ed1. Yes, i do see that and my FL Studio is configured as such. I have the midi output set to 1 on Scaler and midi input set to 1 on Xpander plugin, yet I do not here any sound when i press keys on Scaler. I cannot understand why.

Are you using patcher ? Is your external VST connected to the sound output ?

Hi dudaman

Go to FL browser at your left, click at plugin icon at top right and you will see your plugin database, then click in Installed, Generators, and you will see a VST3 and a VST2 folders, witch contains your plugin versions , open it, and just drag and drop Scaler VST2 to FL channel/pattern rack.

1 Like

Does anyone know how to route 1 instance of scaler to several different midi channels for external hardware so that one scale chord setting will affect a bunch as I choose?

I have it in patcher going to 1 instance of midi out. BUt i have to change the channel each time.

I am also getting hung notes when doing so. It seems to have something to do with the allow multi-trigger option being ON.

Thanks for the reply Dionisio, but I dont even see a VST2 folder… only VST and VST3 folders. And it doesn’t appear at all in the VST folder. Scarler only appears in VST 3 folder. This has me so bummed out… how can you sell a plugin that doesn’t work the way you would like to utilize it? Sure, I can export the midi of the chords to the XPander plugin, but I would like to use the sounds of Xpander while playing the chords in real time in Scaler! Sucks.