Scaler 2.2 problems with Cakewalk by Bandlab and MIDI drag

For the most part, Scaler 2.2 works well in Cakewalk by Bandlab, but I have a problem that has caused it to lock up and crash both itself and Cakewalk. There are two issues. One is that when dragging midi after a capture, frequently there are multiple clips that get dropped in place. I almost always have to delete one or two of them, and make sure none are hidden underneath. The other more serious problem is that when dragging and dropping, Scaler 2 will sometimes lock up completely, and there is no way, other than to End Task on Cakewalk and lose whatever work you’ve done since saving. This happened to me several times while composing my latest piece. I think it can be reproduced by dragging a clip off of the interface, and not dropping it in Cakewalk, but dragging it back to the interface, though this only was the cause one of the several time that it happened. I had decided I did not want to drop the clip without making changes first.
I am running on a Dell Workstation PC with all SSD drives and 12Gb of ram on Windows 10 latest version.

1 Like

I have noticed the same issue with Sonar Platinum were multiple copies are placed on top of each other as if it is doing 2 paste operations

I can also confirm the multiple paste issue in Cakewalk. My recollection is this also occurred prior to 2.2.

Appears to work in 2.2 per my tests (so far :grinning: ) Correction….I tested pasting to the scaler track and that worked. However, if you drag from Scaler to another instrument track you get 2 copies. This is a bit of an issue because you have to look and see if you have underlying duplicates else editing and moving clips around gets rather cumbersome.

Yes, I was pasting to an instrument track, not to the Scaler 2.2 track.

Here is an example of Scaler 2.2 locking up in Cakewalk.

I have to quit Cakewalk and re-open the project to get Scaler to work again.

I have the same issue. After a period of time or perhaps number of times I open the instance of Scaler, I get a blank screen as shown above. The only way to correct this is to close the DAW and reopen it. I am using Sonar Platinum.

This is why i am on here today. Locking up, no solution I can find so having to close Scaler 2 and Cakewalk. It has happened 4 times and 4 times i have gone back in and made a new track. Still not working. I recently upgraded to 220.
I am a beginner so maybe there is an answer?

Check this out. I had the same problem and it seemed to solve it:

I’ve had the same issue with CbB placing multiple copies of clips (usually two) on top of each other when dragging out midi from Scaler. It’s not a big issue to remove the extra copies of the clips(once you know to look for it) but it does slow down my workflow.

This has been fixed with the latest version of Scalar and Cakewalk.

1 Like