Scaler 2 and Instascale causing Ableton 10 to crash immediately Win 10

Hi there,

I’m new to the forum and new to Scaler2 and Scaler Audio2. All installation went well as far as I can establish. When I try to open any of them, a separate window opens up, it stays black and then Ableton 10 crashes. I have tried re-installing but no luck. I’ve looked at the fix for another forum member but that fix won’t help (my sample rate is 44100 and buffer size 1024).

I’m using Win 10, Intel Xeon @2.9gh 64gb RAM
Scaler v 2.2.0
Please help!


maybe it’s not useful in your case, but I think that the sample rate must be identical in the Operative System (both recording and playing options) AND in your ASIO card, if you use it

in other words, all audio devices in your computer must have the same sample rate, and the same bit depth BTW

Hi @lord_shine

the fact that the screen stays black points to a graphic issue, either a missing GPU driver or an incompatible OpenGL version.

You can disable OpenGL Rendering from the ScalerSettings application:

  • Press the Windows key to open the search and type “ ScalerSettings
  • Go to the Help page and click “Turn OFF OpenGL”:

Thanks @Ed1 it worked a treat. Many thanks!




Most likely you do not have Microsoft Visual C++ libraries on your computer that help plugins to work normally. (this is for windows for mac i don’t know) If you have Windows then download from the Microsoft website, if you have a Mac, then ask google what libraries you need.

Fantastic! Sorted it. Many thanks