Scaler 2 crash

Hello again wonderful people

Trying to use the “explore scale” function from the right click menu on a chord crashes scaler. That is as soon as a new scale is clicked in the “explore scales” menu Bitwig freezes.

Scaler 2.0.2 VST3
Bitwig 3.1.3
Windows 10


Scaler 2.0.2 Crashes In Reaper 6.10

Trying to detect the chords for my melody. Playing 3 notes and on the fourth one, Scaler crashes. I tried at least 10 times, every time the same. Sent to debuger (VS2019) and see this:

Unhandled exception at 0x00007FFFB809CA30 (Scaler2.vst3) in reaper.exe: 0xC0000005: Access violation reading location 0x00000000178F9000.

This worked perfectly during the Beta testing.

Thanks for reporting, we will have a look.

Does this affect sessions created with the beta or new sessions as well ?

Hi Ed,
This happens with both the new session, directly played on my keyboard controller or recorded, and the session already created with beta and previously saved.


Just a quick heads up. I also have had several crushes with Scaler 2.0.2 and the current Reaper. Reaper fully shuts down! never saw this with the Scaler Betas. At one point I was adjusting preferences and the Scaler GUI was messed up. Before I could blink it just shut down Reaper. After restart all was well.Will pick up where I left off tomorrow and will keep notes to see if I can identify what actions cause this.

I’ve had several crashes of Live on MacOS for me. I can’t reliably reproduce it, when I restart the daw it starts working again.

I’m experiencing the same thing. Ableton Live Suite with Scaler 2 - after 3 notes, the fourth note crashes when trying to determine the scale.

Me too. Just bought the upgrade and it crashes every time, when it crashes it closes Live. :frowning:

Hi @Marcel, @Miki, @MusicStudent, @poolontheroof, @Radnor and @Joby.

Thanks for reporting, could you provide us a bit more details such as :

  • platform OS and version
  • DAW version
  • VST version (VST2, VST3, AU)
  • Scaler version (Scaler 2 or ScalerAudio 2)

we are investigating it.

1 Like

Windows 10
Ableton Live Suite 10.1.14
VST 2 & 3
Scaler 2

Works 100% of the time with Scaler V1. My intuition tells me it’s something to do with the new soundset. I’ll reinstall it without the new sounds and report back.

@Joby you can also try reinstall with the sounds and then reboot your computer.

So I tried reinstalling, nothing changed (even crashed with no sound selected). Then I reinstalled but allowed it to install in the Steinberg VST folder, previously I had selected my own custom VST folder. This time when it loaded I didn’t go straight for note detection, just played with some other features, then when I went to note detection it was working. Cool.


Windows 10
Reaper 6.10
Vst3, vst2
Scaler 2

I already have my 64-bit Vst in Cakewalk folder (so I did not change it) and I tried what Joby suggested - to play around in Scaler and then go to Detect. Unfortunately, the result was as usual - crash.
I’ll try with Reaper 6.11 which I did not downloaded yet but will do soon. I’ll modify my comment only if there is an improvement.

OK, With Reaper 6.11 - no change if I detect directly from the keyboard (the one in Scaler UI or my controller), but…
I recorded my melody on track and then clicked Detect. This worked like a charm.
I played more and tried other stuff. Then I deleted the detected chords and once again tried to detect directly from my controller. This worked, too.
Closed Reaper, reloaded the project, retried the same sequence as previously - Crash!

I’ve tried in Pad-mode to trigger a pad with an external controller (Maschine Jam) and Scaler crashes.
How to solve this?

Win 10
Ableton 10
Scaler 2.02

Scaler doesn’t support midi mapping at this stage. It’s coming, but not supported yet.

VST3 Crashes instantly in Bitwig
VST2 Crashes after note input in detection mode in Bitwig

Trial version 2.0.3
Win 10
Did not install sounds, only the app

Hi there,

I am also experiencing crashes when I play notes into Scalar 2 (and trying to detect the key). See below for the details.

Thanks for looking into this,

  • Windows 10 Pro
  • Ableton Live Suite 10.1.14 (Live crashes and exits too when Scaler crashes)
  • Both VST2 and VST3
  • Scaler version: Scaler (2.0.3)
  • I’ve tried installing the VSTs in the (default) Steinberg VST folder and the issue remains.

Licensed 2.0.3, Win 10, Bitwig 3.1.3 AND Bitwig 3.2 beta 7
Note that all my Plugins are set to run in “By Manufacturer” sandboxing mode.
All my VST2s are installed in custom C:/Program Files/VSTPlugins path
All my VST3s are installed in the default path
All new sounds installed with Scaler 2 in the default path

Scaler 2 (VST 3 AND VST 2) in a NEW session

Can confirm that right-clicking > “Explore Scales” causes problems. In my case it doesn’t crash Bitwig nor Scaler 2.0, but it DOES cause incredible laggy response time to any mouse clicks in the Scaler window. Also, nothing actually happens when choosing “Explore Scales”–no new UI changes of any sort; just incredible lag. Closing the pop-up VST window for Scaler, and then re-opening the VST window, seems to clear the error condition.

Can confirm that enabling Detect > MIDI > arm recording, and then manually playing successive notes on my controller will insta-crash the Scaler 2 plugin after the 3rd note or so.

Again, these issues occur in both VST2 and VST3 instances of Scaler 2. They also occur in both the current production 3.1.3 release of Bitwig, and also in the latest 3.2 beta 7 release of Bitwig.

My system
Cubase 10 pro
Scaler 2.02

I am also experiencing crashes

Same pattern ↓

Can confirm that enabling Detect > MIDI > arm recording, and then manually playing successive notes on my controller will insta-crash the Scaler 2 plugin after the 3rd note or so.

Again, these issues occur in both VST2 and VST3 instances of Scaler 2.

Regular crashes after detecting chords with Felt-Piano.
Crash during editing.
Scaler crashes - so Ableton also crashes.
The new features are great - but currently I can’t work with this tool.
I bought the update. I’m not a Beta-Tester. This is frustrating.
What are your proposals to solve these problems?

Win 10
Ableton 10.14
Scaler 2.02