Scaler 2 dragging

Hi:) I’m using Scaler 2 with Magix Samplitude Pro x3…
When dragging a chord or pattern of chords into Samplitude daw the next set of chords or patterns I create are not updating and Scaler outputs the previously dragged chords?

Example: drag a Cmaj chord from the Scaler interface into daw works and then try and drag a Gmaj chord from Scaler…the Cmaj chord is dragged again into daw not the Gmaj I tried to drag.

Thank you for the help:)

Hi and welcome @Windmill Very hard to diagnose what sounds like odd behaviour without seeing it. Can you post a short video?

Hi:) thanks for the reply…attached is a video of what I’m trying to describe…thank you:)

I’ve tried turning off Marker names but makes no difference….

What if you drag the chords to the desk top and then into the DAW? What version of Scaler is that? It doesn’t look like the latest one.

Hi…yes I tried to drag to desktop and back into daw and behavior is the same…it is Scaler 2.4
I purchased from Plug-in Boutique a few weeks ago👍

I see now. I never use Scaler like that so I hadn’t seen that page exactly that way.
I can’t duplicate this on a Mac so someone with a Windows machine will need to chime in. Good luck.

Hi I replicated your actions using Studio One 4 & Win 10 & all the chords worked (i.e. changed) as I would expect them to. Hopefully support can get you sorted, good luck.

You aren’t giving the Devs enough information. They need you OS for one major thing and maybe a bit about the computer you are running on. Do you have another DAW you can try Scaler from?

Hey Windmill;

I use drag and drop almost exclusively with Scaler and have been using it that way for years. I’ve never seen it act like that.

As @jamieh suggests, some more system info will help people troubleshoot/replicate.

2 things need to happen. 1, someone else needs to replicate your issue 2, we need to determine if Scaler is delivering the wrong chord or if your DAW is somehow reading old data.

A couple things to try

  • Try dragging from a different Scaler pane (A, B or C) and not the Chord pane. Pick a Scale, drag a couple chords from section B and then drag a couple other chords from section B
  • Try clearing Scaler state (right click on Scaler Logo) between chord drags
  • Try dragging a chord outside of Scaler (until you see the + icon) but do not drop…then drag back over scaler and drop. Scaler will do a detect and it should be the chord you dragged out.
  • Try Dragging to your desktop and then dragging that file back into Scaler and it will do a detect. Does it match your expectations?
  • Try turning on midi capture (pane C) and playing a few notes or chords. Stop midi capture and then click & drag the Drag button to your DAW or Desktop.

You might also consider loading something like NanoHost to test just your Scaler instance. A number of forum users use it (I do almost every day) It is free, simple and almost nothing to install. Scaler 2 Standalone version - General Discussion - Scaler Plugin - Community Forum

Good luck…D&D is one of Scalers great assets.

1 Like