Scaler 2 Frozen By Beatport Access

First I tried to rent to own Scaler 2, Installed the Beatport Access & it DIDN’T WORK! Gotta refund Then purchased it in full, Still doesn’t work, Stating it’s frozen because Beatport has to be running to fix license, Was told once you have a perpetual license Beatport Access is not needed. The message says otherwise, I just want help getting this to work, Or my money back, I’ve been uninstalling / reinstalling, Rebooting all week & still not working, I can’t toggle anything because Beatport doesn’t work. I am using Mojave 10.14 O.S.

Hi @djkrissneal and welcome to the forum. Please check the following for a solution:

Tried the uninstall thing & reboot didn’t work, & there is no earlier version in my account in drop down tab all I see is 2.8.2. Where do I find an earlier version?

This is what I see in my account, if you’re not seeing the same thing you need to address with Plugin Boutique. Scaler 2 sales are handled by Plugin Boutique and Beatport studio is a PIB thing so there isn’t anything we can do on this end for you other than try and help.

OK, I’m finally able to run scaler only when Beatport is running in the backgound No where register the license when I purchased scaler, Doesn’t show in Beatport Access that I own scaler. How can I register my license & run scaler without running Beatport in the background.

OK, My 2.8.2 version of scaler 2 only works when Beatport Access is running, Recieved a 4.99 Refund after Cancelling Scaler 2 rent to own, Purchased license for 39.99 Sat. 4/6/24, Order # 49478496, No where to register the license, Because it only works with Beatport Access, Able to log in on Beatport Access for the first time Fri. 4/12/24 & it only worked for that 1 night, Now it’s back to reading errors when attempting to log in, Also noticed Scaler 2 only showing in my subscriptions as a cancelled order, & not as a license purchase. I think the cancelled rent to own order & Beatport Access is the issue here, Any way to re do this order & register the license so I don’t have to rely on Beatport Access? Very frustrating trying to get this working properly. Thanks In Advance.

Hey @djkrissneal You really need to have PIB help you with this, just to be clear- Beatport Access is not our product and when you use it or Rent To Own you are using PIB’s proprietary system so issues need to be raised with them. Having said that, and to reiterate to try and help you: Have you checked through that thread I posted earlier. Specifically:

When I log in Beatport Access, I see Scaler 2 in my subscriptions as a rent to own cancelled order, Beatport Access showing it as if I didn’t purchase it, Even when I tried the rent the own & installed everything, It kept reading an unexpected app error. I thought maybe if I purchase it in full and get a license that it would work. Unfortunately it didn’t

Where is the download button in PIB? Because when I tried the rent to own, They sent a link to my email to download Beatport Access

I see the download button for Rent to own.

Saw this in my email update for the forum, and I wanted to give my 2 cents. I recommend and suggest not to use Beatport for rent to own. I say go ahead and buy Scaler if you are curious and want a great music theory and composition plugin. I gave up on renting to own Scaler EQ because of Beatport access hanging up. The last straw was that I completed the captcha about 30-40 times and it still wouldn’t log me in. Deleted. I wish they would have a buy-it option after renting it for a little while. It’s all bad programming and policy if you ask me. I know Scaler has nothing to do with it besides Plugin Boutique making it mandatory if you rent to own a plug-in.

1 Like