Scaler iOS: No IAP without internet connection... FIXED

Gents, having waited expectantly for Scaler 2 iOS, I am pissed to find that I need to have internet connectivity to get what I paid for. An app specifically ported to a mobile device should NOT require this out-dated approach to ensure the user can actually use the damn app. When can we expect a proper fix to this?

Hi @sch and welcome to the forum.

You should still have all of the purchase unlocked and available when you are offline, you do not need to be connected to the internet once you have purchased and downloaded all the features. This is just a graphical bug and will be addressed in the next build.

2 Likes

If this is a graphical bug, then why do the additional instruments not appear for use this condition?

I’m having the same issue. Developers: Turn off your iPad’s wifi and load Scaler 2 as an audio unit. You will see what we’re talking about: All the features paid for are unavailable.

Hi @sch and @matthew we are sorry that you are experiencing this.

I am having a great deal of trouble replicating the behavior you mention as through my testing with or without wifi the extra features are available including the additional instruments. If you have any specific steps or order of actions that can consistently replicate this behavior please do let us know here so we can reproduce it.

Whilst we are having trouble replicating this we do take your reports seriously so the team is looking into this to see whether there is some obscure cause and the possibility that this may not just be a graphical bug. Any information you can share with us to help replicate is appreciated.

@James,

I tried to recreate it too, and although I was incorrect about the instruments not appearing, I found that if I tried to gain access to the Sequencer, for example, I got the IAP purchase pop-up, which as soon as I tried to dismiss it, instantly dropped me back to the “Home Screen”. This happened repeatedly.

To add to the confusion, I tried to recreate this just now to compose this reply, and got no pop-up, and all seemed fine! At this point, I’m happy it is not occurring, but still confused why it did so before (at two different times, once away from any wi-fi, and last night, home but in airplane mode).

Thanks for the quick replies, and I am anxious to start using this amazing app. Looking forward to updates and finally learning some more music theory. Keep up the good work!

Hi @sch we have the team looking into this now so hopefully we will have an answer and a fix very soon. Thank you for sharing and I’m glad that you are able to use Scaler fully now.

Thanks, James, it’s a pleasure to deal with you. Ciao!

I don’t know if this is the case, but many (if not all I know, and not only in the musical field) apps requires an Internet connection JUST the first time after installing them, while after they work offline

If it’s the case, maybe that devs have only to pop-up an advice during the installation

cheers

@ClaudioPorcellana, Unfortunately, this isn’t the case for me… I bought Scaler 2 with the full unlock the instant it was available, and have been using it since then. The issue only occurred a few days ago when, for the first time, I was using it at a location with no wi-fi.

Ciao!

1 Like

Curious. I use glasswire https://www.glasswire.com/ running to monitor my network, so I just looked to see if any of the VSTs I run in Cantabile https://www.cantabilesoftware.com/ ‘call home’.

I fired up scaler and checked for traffic from Cantabile
glass 1

so nothing on the wired net. Scanning wifi connections gave

network
Nothing obviously there either.

As a sanity check (and to make sure that VSTs within Catabile showed up), I started Captain Epic, and (as expected) and it appears to call out to another server to load patches.
glass 2

So at first glance, Scaler has no external connections when running.

Although he is running the iOS version not computer, but there still shouldn’t be any real need for a connection.

Hello all,

On my iPad, I actually get locked out of the other tabs regularly until I connect my iPad again to the internet:

I can go offline again after it detects the IAP but eventually it gets locked again when I try to go in again the next day. Hope the video above helps. Happy to provide any other info.

2 Likes

Just to confirm, this is exactly what I experienced.

Hi, I’m experiencing this issue too on my iPad mini6 - IAP won’t stay unlocked without internet connection. Thanks

1 Like

Hi, any update on this?

FYI, Scaler will not let me use it without internet connection, it locks me out of Seq tabs, etc.

Also to reproduce the problem: don’t use Scaler for a few days, turn on airplane mode/turn off WiFi, start Scaler, it will popup a msg saying it can’t verify purchase, then tap the Seq tab to get another popup saying it’s not available without purchasing.

Thanks for reading

Any reason you don’t just leave WIFI on?

just to add another to those experiencing this problem …

i have an ipad that i keep offline (it is running an earlier ios) …

i “restored purchase” a day or two ago (to get rid of the problem)

but sadly, the problem - functionality shutdown - has returned.

1 Like

I like making music outside, where there are no distractions. Also it saves battery & you get better performance when not using wifi. HST, I shouldn’t be required to have an internet connection to use an app I’ve already paid for.

Also it’s not clear from @james last reply whether he knows that people can’t use Scalers IAP features without internet because he ends by acknowledging the last user managed to resolve it - But for lots of us it is still unresolved, ie not working.

@offlineLife Excellent name! :+1:

Hi @Gdog

yes, this will be patched in the next update.