Scaler starts a beat late in logic

Hi, I have been having an issue where scaler starts a beat behind in logic. The sync is working and loops correctly but scaler is a beat late every time. I cannot figure out why and have never had this problem. I didn’t update anything. Is there some kind of setting I am missing?

HI @adamhain Welcome to the forum, any chance you can post a link to a video which shows what’s is happening?

Hi @adamhain and welcome to the forum.

Would you be able to share some more information please.

Do you have performances enabled? Does this only happen with DAW sync enabled etc etc. Any specific steps we can follow to recreate the issue you are having will help us greatly.


Thank you so much. Here is a link to a quick video I took with my phone. As you can hear the loop starts one beat late every time.
This happens with performances enabled or not and also with DAW sync off and on. I have used scaler quite a bit and never seen this. I can also post pictures of my settings.

To follow up here are a few screenshots of my settings.
This has been happening in all my sessions and in all instances of the plugin. I tried reinstalling scaler but it did not help.

Thanks @adamhain

Would you please try enabling “Play Quantize” in the settings menu and see if this makes a difference to your performances?
Using the example in your video if you could.

Let me know what results you get

Hello, thanks! I followed the picture and just tried that but it didn’t make a difference.

Thanks @adamhain

Does your project happen to start before the first downbeat?
As in the screenshot below.

DAW Sync doesn’t grab a hold until the first downbeat so projects that have their project start marker before bar 1 will find that Scaler DAW sync won’t kick in until the start of bar 1.

That’s the only way I can reproduce your issue currently.

Are you also able to confirm that this is affecting all of your projects? Including a new blank project?

Thank you. Yes, I have the session starting at bar 1. I did try a blank session in logic with just one track and the problem went away! However all my projects begin with a template and it appears to be happening in all of these.
This is odd though because I did not ever have this problem before with the same template…I cant think of a project setting in logic that might be causing it…

Actually I think I may have an answer! I can recreate the problem by turning off low latency mode in logic. So when I turn on low latency the problem goes away and when I turn it off it comes back. I will test further and report back!

1 Like

Can you try turning off Open GL and see if that helps?

Thank you for sharing this! I will try it. But I haven’t been having the issue as much. Though it does happen here and there. I have been solving it by toggling low latency monitoring. Oddly the position doesn’t seem to matter. If it happens to be off or on toggling fixes it…

Hey @adamhain
Apologies for digging up an old post but would you happen to be running off an external clock in your setup by any chance?

Hi James,

No, no external clock here.

I do still see this issue quite a bit but toggling low latency monitoring seems to fix it.

Thanks for checking in!

Strange that you are only seeing this in your templates. Often cache in old templates causes me problems with recent Logic updates. I always rebuild my templates every year or so. Either way, it seems you must have inadvertently toggles a project setting in your template. Here’s some screenshots of mine. See if matching mine helps.

Thanks, I looked at these and they look the same as mine except the sync window. I matched to yours but still have the issue. Turning on LLM in logic fixes it though.