Show Chord Name when Chord is dragged into Bitwig


When I drag a chord from Scaler 2.8 (VST3) into BItwig the clip that is created gets the name: ‘Scaler-Chord-With-Markers.mid’.

It would superb if the clip would simply get the name of the single chord.

If dragging multiple chords at once, having them all appear in the name, separated by a space would be great too.

If this is already possible, please advise. Thanks!

Did you get the info you need? The Manual indicates that it works in some DAWs. My experience is that it works in some DAWs some of the time. The Manual indicates:

Export MIDI Markers
When dragging chords to your DAW, Scaler will insert markers in the exported MIDI to define and name the area of each chord in your progression. This feature is not supported by all DAWs

When working for me it looked like the shot on the left. When not working, the shot on the right.

I stopped using Scaler on v2.73. I want to check in again next version and would be so happy to find this working consistently. :wink:

I would say that this is purely DAW thing. In Reaper, for example, I have absolutely no problems and I have my chords’ names all the time when I drag from Scaler. There are some settings that, of course, I forgot because this is the kind of things you do “once in a lifetime” and I certainly did something and names appeared.
Scaler has nothing to do with this. Some DAWs will do it correctly, the others not. As many other things that one DAW support and another one not.

I’m not certain about that.

My question is not about markers, or marker names. It is about the clip name, which would I think derives from the intermediate MIDI file name (or the intermediate non-file proxy for), which is written by Scaler, no?

IOW, what is written name-wise from the output (Scaler) side is what the input side (Bitwig) will see and use. That’s what I would think. If that’s not a correct assumption, I would appreciate being authoritatively educated here as to where that name ‘Scaler-Chord-With-Markers.mid’ is generated in the first place.

@panda has made studies in all that. Maybe he can chime in here.

You can check it by opening the midi file in a hexreader.
Some have it:

Some don’t:

At least as of 2.7.3

1 Like

Referring to mbrown’s pics above, notice in each that FF 03 is followed by ‘Scaler-Chord-With-Markers.mid’. That’s the defined Sequence/Track Name.

Here is a quote from the MIDI File Specification:

FF 03 len text Sequence/Track Name
If in a format 0 track, or the first track in a format 1 file, the name of the sequence. Otherwise, the name of the

This is the point! (this is the name I’m talking about)

The request is for the FF 03 data to be “Amaj7”, or “Cm7 F7” or similar, as per the names of the chords or chord sequence as Scaler knows them.

Of what use is the clip name ‘Scaler-Chord-With-Markers.mid’? To me, it is of no use at all, and requires tedious manual changing EVERY SINGLE TIME.

If it is of some use to somebody (really?), then OK, please give us a user option (instead of a single new behavior) as to whether we want to export with chord names or export with ‘Scaler-Chord-With-Markers.mid’.

This change would be a major time-saver every day Scaler is in use with a DAW.

The goal is conceptually simple (and programmatically straightforward, I would think): when dragging chords (and chord progressions) from Scaler into a DAW, the resulting clips in the DAW will be automatically named per the chord (or chord progression) which is inside.


P.S. None of this need affect what is or isn’t done with markers at all. Markers are their own thing, long live markers! :slightly_smiling_face:

I wrote some stuff about this in 2021, and tried Live again just now to see if anything changed in behaviour.

{1} If you drag a single chord in section C from Scale to Live, then it shows in the track clip as ‘Scaler-Chords.mid’. This has nothing to do with the file name. You can test this by dragging the mid to the desk top, renaming it it and then dragging it into Live.

{2} If you switch midi markers on in ‘Settings’, imported midi is then titled ‘Scaler-Chords-With-Markers.mid’ ; again, the clip file name has no effect on this, so it appears to be ‘hard programmed’.

{3} With markers off, no chord data is shown in the midi track meta data… With markers on, the meta record has either the chord name or the chords in the sequence.
So a section C thus

cap 1

has the following meta data
cap 2

So Scaler does write the name of the chords into a midi file when markers are on.

{4} If you re-export a file which originally had midi markers in (as above), they are not there when exported from Live., So as they were there before import, and gone after import, it is Live that has ignored or deleted them.

{5} So for a controlled test, I cleared state and just put a Cmaj triad into section C

Here’s the hex

We can see that has gone into FF 03

FF 03 11 53 63 61 6C 65 72 2D 43 68 6F 72 64 73 2E 6D 69 64 9E 00 80 30 6E 00 34 6E 00 37 6E 00 FF

Now switch markers on

and we have the Scaler ‘markers’ text into FF03

FF 03 1E 53 63 61 6C 65 72 2D 43 68 6F 72 64 73 2D 57 69 74 68 2D 4D 61 72 6B 65 72 73 2E 6D 69 64 9E 00 80 30 6E 00 34 6E 00 37 6E 00 FF

But we also see before that the ‘Cmaj’. It appears to have gone into FF 06, which the MIDI spec defines as ‘Marker’.
FF 06 05 43 20 6D 61 6A 00 FF

So in the case of Live (I have no idea about Bitwig, but @Bernd or @jamieh might chime in) it seem reasonable to conclude that

{A} Scaler puts fixed text into FF03 with or without the ‘with markets’ annotation

{B} Live uses FF03 to name the imported track clip (not the file name).

{C} Scaler appears to put chord data (either as a single chord or as a sequence) into FF06

{D} Live ignores FF06 on either import or export.

There is one other thing from your examination which you might be able to throw some light on. The MIDI spec (96.1, as amended) defines metadata in FF03 as being for Format 0 (as these clips are) as the “Sequence / Track Name” (as you stated)… There is no mention of it holding chord naming data per se, or is the correct interpretation of “Sequence” here the chord sequence ? This sort of seems at variance with the definition of 'Sequence Number" given against FF00.

There shouldn’t be any problem with it being in there, but will a DAW read that ? It would only be meaningful in track name terms if you exported the chord one at a time from Scaler, and that would cause a problem in a DAW like Live.

For DAWs that do show chord names with Scaler output, they must be picking it up from FF06.


Panda, nice specifics!

I find it all entirely consistent with what I’ve written and requested.

Contents of FF 06 is marker info. DAWs that use that info will do their thing with it. Other DAWs will ignore it (that’s on the DAW).

Contents of FF 03 is the Sequence/Track Name. That’s what just about any DAW will display as the clip name when imported.

Any DAW that currently displays ‘Scaler-Chord-With-Markers.mid’ as the imported clip name is doing that because Scaler wrote ‘Scaler-Chord-With-Markers.mid’ in FF 03.

If Scaler would write the chord name(s) (the full chord names, and nothing but the chord names, hehe) in FF 03 then that is what the DAWs would display as the clip names. Yes! That is what is desired here. Thanks.

I note that Scaler is already “dealing with” the chord names by putting them in the marker field (FF 06).

So, it’s not like some whole new analyze and fetch algo is needed. Just concatenate the chord names as already available into FF 03 instead of putting in the currently useless “Scaler-Chords.mid” or “Scaler-Chords-With-Markers.mid” text.

Dare I say, this should be easy-peasy to accomplish. (famous last words!)

Is there anyone who doesn’t want their imported clips to be named according to the chords within them?

I dare say it will not be that easy. I realize that I’m one of very few users experiencing the bug, but for me Scaler does not even include the chord name in the Scaler-Chords-With-Markers.mid file.

Since this issue has come up again, I installed the current 2.8.1, having given up back at 2.7.3. This is a clean install on Win10, having deleted all references to Scaler on drives and registry.

I ran Scaler in two different hosts, and opened the resulting Scaler-Chords-With-Markers.mid files in a hex reader. In neither case was there a chord name in the midi file. So, I believe this means that Scaler is not putting the chord name into the midi file. They may have to solve this before they can use that chord name in the filename. I do realize that it works fine for most people.
Hosted in Reaper:
Scaler Reaper
Hosted in VSTHost:
Scaler VSTHost

If you took the midi file from the host, it is likely that it stripped FF 06 before doing so, Try the exporting either a chord or chord sequence from scaler to the desktop, rather than from a DAW track, and looking at that in a hex editor.

See my post above

Nice to have your eyes on this! I guess I could have been clearer… I dragged the chord directly from Scaler, (not to a DAW or other intermediate app) to desktop and also directly to HxD in case the desktop might be confounding.

Hi mbrown.

Just to be certain, do you have the Export MIDI Markers preference setting ON ?

Scaler - Export MIDI Markers Setting 01

1 Like

Well I understand your skepticism :grinning: But, yes I do. It shows in the attachments in my above post.

Here’s what it looks like with Markers in Scaler turned off:
No Markers

And there’s only that one control, so it should just work.

Here is a program specifically for low-level MIDI file editing:

MIDIopsy - Software by Jeff Bourdier

The parsing and view makes much clear that is otherwise kinda hard to see right away, and also the editing ops via Properties automatically save you from making alot of malformed stuff that would otherwise be easy to make.

Here is a small 2-chord export from Scaler, renamed via FF 03 and dragged into Bitwig.

Joker Result 01

And here is one more like what we really want to see:

Dragged into Bitwig:

E min F maj Result 01

Dragged into Studio One:

E min F maj Result 01 - Studio One

Feel free to check the import in your DAW(s) of choice!

E min F maj.mid (116 Bytes)

FWIW, my “data point” report with Scaler 2.8.0 (VST3), Win 10, and Bitwig 5.0.4 is that

a) Scaler puts the chord info in the marker area as expected

b) (though this is of no value here)

c) and Bitwig is “ready to receive” into the Clip Name whatever Scaler takes the care to write into the FF 03 area.

d) which I heartily hope will be the chords, real soon now! :slightly_smiling_face: