Unresponsive Scaler 2.5.0 on Apple M1

I have come back to use Scaler after some time (2.5.0, both VST and VST3, running in Bitwig Studio 4.1.2 on macOS 12.0.1 on Apple M1 Pro) and I am finding the UI very unresponsive. Watch this video to give yourself an idea: what you see is real-time, without any post-processing but for highlighting the mouse clicks.

It is not normal that it is so slow, right? Is it a known issue or it is just me? Thanks.

G.

1 Like

2.5 working fine here on Bitwig 4.1.2 but on Windows. Have you tried changing the Bitwig Plugin Hosting options this sometimes works for me when Plugins misbehave.

1 Like

@tactile_coast thanks for the suggestion, yes I’ve tried that, and I have also tried the VST 2 version, the behavior is the same. My best hypothesis at the moment is that the VST is not yet compiled natively for Apple silicon, and for some reason that affects especially the UI.

Can confirm this issue, Scaler 2.5.0 on Bitwig 4.1.2 feels very sluggish on my M1 Macbook Air.

2 Likes

Still no news? It takes off all the pleasure of using it!

1 Like

SAME ISSUE. Latest M1 MacBook. And its super slow.
I am planning to perform live and it feels like this plugin won’t do the job!
How do I contact technical support? There is NO “Contact US” button on their website.

1 Like

Hey @MantisStorm

here :slight_smile:

Not everybody is experiencing this slowness on M1, this is a bit odd, it performs OK here on my machine for example. Is your CPU/GPU running hot? Do you have anything else running on the machine? Is there any other sign of slowness anywhere?

The next update will contain performance improvements on top of new features and new content so hopefully your issues will go away.

We are still working on it right now, we’re a few days behind schedule so it will be early March instead of end of Feb, but it is coming really soon.

Thanks for response.
CPU is 2%
Not running anything else.

Waiting for the update.
Thank you.

1 Like

CPU is perfectly fine here, too. I am using a MacBook Pro 14-inch 2021 running M1 Pro.

A hint for you, the problem seems worse when using an external display. I have an LG Ultrafine 5k. I correct myself, the problem is not better without using an external display.

Thanks Ed. Hopefully Apple Silicon / M1 Support is coming soon to Scaler. I am having strange issues on my M1 with Scaler. For example, now when I MIDI Capture and drag that MIDI to a track, it is incorrect. I tested this on my Intel mac and it works fine in the same Logic session, but not on the M1. Thanks!

All the same here. I bought Scaler a few months ago, and from the start, it’s been so slow that it’s basically useless in any session. Every button click takes ~10 seconds to load anything. Big shame because it seems very helpful.

1 Like

The same for me as well, but only in Logic Pro X. Scaler 2.5 is slow on M1 in Logic Pro X.

1 Like

You can try to disable OpenGL Rendering from the ScalerSettings application, this should make the UI more responsive:

  • Press CMD-Space on macOS to open the search and type “ ScalerSettings

  • Go to the Help page and click “Turn OFF OpenGL”:

Here’s another post about this:

Let us know if this helps

Thank you for sharing this tip! It works! Scaler is much faster now :wink:

What a rendering strategy will Scaler use if OpenGL option is disabled?

I am asking, because I see that issue sometimes.

What kind of information can we provide to help you to troubleshoot that issue (logs, memory dumps, etc.)?

It does not use the GPU when OpenGL is disabled. The issue seems to be coming from changes in the way the rendering works in later macOS systems. Not everyone with M1 seems to be affected (it works fine here on our test machines with M1 and latest Monterey version).

We are looking at ways to improve this in future versions to get the most performance out of the GPU for everyone, but this workaround seems to help in the meantime.

Thank you very much for sharing that!