1.2.1 Detect Mode

How does detect mode work in this new update?

Seems that you get no sound or midi into scaler unless 1 of the 4 new Bind modes are chosen, which rely on a song or progression to be pre loaded.

Im certain I’m overlooking something.


You are not overlooking anything, there was an issue with this new bind mode. We have fixed it and replaced the installer, but it seems that a few people had the time to download the broken version before the change was effective.

You can re-download the version from Plugin Boutique.

1 Like

I’m having the same issue in fl studio 12. after routing the midi channels correctly, detection doesnt work when using the piano roll. Scaler does detect key presses using my midi controller and if i click on keys on the scaler plugin. I reinstalled 1.2.1 and that didn’t solve the problem so i reverted to 1.2.0 and it’s still not working

If the detection works when using your MIDI controller then it sounds like a problem in FL Studio are you sure the piano roll is sending MIDI to the track Scaler is on ?

Re-downloaded version from PB, seems to work for me again.


this is what i am doing. i put minibit in one of the slots in the instrument rack, i set its output to 1, i set scaler in another instrument slot, i set scaler’s input to 1. Then i make a pattern using minibit’s piano roll. i press play and then i start the detection and Scaler does nothing, doesn’t play a sound, doesn’t show notes, it does however work (randomly) if i select one of the bind mode buttons. Then it “listens” to the piano roll. It’s not a fl studio problem as the midi channels work as expected with other plugins. After reading this topic i uninstalled the plugins, reinstalled them from a fresh download from pluginboutique and the problem persists. The issue is also present in 1.2.0

Ok, there are two possibilities:

  • You might have it setup the wrong way around. Scaler is acting on the MIDI signal so it should listen to the MIDI input (for example: piano roll or MIDI controller) then you redirect Scaler’s output to your synth.

  • There is also the possibility that I misunderstood what you are trying to do and this is just related to an issue with the VST3 in FL Studio where Scaler doesn’t redirect the MIDI properly. Try with the VST2 version.

Have a look at this thread: MIDI Routing - FL Studio - VST3

if i want scaler’s input to affect my synth i set scalers output to channel 1 and my synths input to channel 1. (this works. if i click on a chord in scaler, i get output through my synth)

if i want scaler to detect my synths input, i set my synths output to channel 1 and scaler’s input to channel 1. (this doesn’t work, the detection doesn’t seem to get any input from my synth. It only does so randomly but only if one of the “bind midi” buttons is activated)

i am using the vst2 version.

Are you sure the synth output contains all the MIDI events and doesn’t consume or transform some of them ?

it doesn’t because i get sound if a bind midi button is active

I have never tried to put Scaler behind a synth as most of them do not output MIDI. And for what I have tried in other DAW, I was able to analyse the output of the another MIDI plugin.

I am downloading a demo of minibit and will try this to see what is happening.

or maybe i am just clueless, regardless if you manage to get it to work, i will really appreciate it if you could explain to me how you set it up because i just cant get it to work

Here is what I’ve done using Patcher, it triggers sounds in Scaler and works in the detection:

I am not an expert in FL Studio so I tend to use Patcher for everything in order to have a visual representation of what I am connecting together.

This is using Scaler 1.2.1 VST2, I hope it helps.

nice, that i haven’t tried. i’ll give it a shot

nope, no sound at all, no detection. will try to reset fl studio’s settings to see if that fixes anything

I bought scaler 1.6.1 today from pluginboutique. I’m using Sonar and Reaper.
In both DAWs I can not get the bind midi to work. I noticed somebody saying there was an issue with an earlier version of Scaler, and there was a newer version that this problem was fixed.
Either I’m not seeing something or this problem is still with the new version of scaler 1.6.1.

Hi @Bozzfrog

the 1.6.1 version is the latest one and the bind midi is working properly as far as I know, there has been no issue reported so far.

What are you trying to do, and what is the issue you are facing?


Must be me doing something wrote!. Everything else seems to be working accept ( bind midi.)

I click it but nothing happens. I am using simular VSTs without any problems. So I’m not sure what I’m doing wrong.

I Must be me doing something wrong. Everything else seems to be working accept (bind midi.)

I click it but nothing happens. I am using simular VSTs without any problems. So I’m not sure what I’m doing wrong.

Hi @Bozzfrog

The “bind midi” allows you to map one of the 3 sections (A, B, C) to keys on your controller in order to trigger chords by pressing a single note.

For example, if you select a song (ie: “Songs” > “Chill”), you will see the “A” button active in the “Bind MIDI” section on the right hand side of the keyboard.

Clicking on the “A” will bind the section “A”. The bound notes will be displayed on the virtual keyboard in Scaler in dark grey.