Scaler EQ not working correctly on Windows

When open in ableton scaler EQ show blank or just black… how do I fix this

Hi @Navado and welcome to the forum. Can you please give us some more spec details. PC Specs / Windows OS / etc?

Windows 10
8GB ram
64bit operating system

I had the same issue with scaler2. But the work a round for that is not working for scalerEQ

What was that workaround? Disable Open GL? Just trying to give our devs as much info as possible.

Open Gl but thats not working

Now am paying for it and its not even opening sad. Think you have to do too much to the scaler products to work

Hey sorry to hear about that and it is indeed sad. But given there are tens of thousands of users and no-one that I know of reporting this issue then diplomatically it would suggest there is something in your setup causing it. I have sent this thread on to our developers to see whether we can try and work out what is going on and of course you are welcome to lodge a refund request with Plugin Boutique whom I am certain will oblige. I personally don’t want that and would prefer you use Scaler EQ as I love it very much. Let’s see if we can help you and maybe some other PC/Windows users may have suggestions.

I have the same problem with CUBASE and REAPER or any other DAW I own.
I’m on WIN 10 PRO 64bits obviously.
When I want to initialize SCALER_EQ for the first time it blocks CUBASE or any other DAW. And my processor is running at 20% of its power [(Intel(R) Core™ i7-5960X CPU @ 3.00GHz 3.00 GHz overlock to 3.89 GHz - 64 GB of RAM]
Force “end process” to close DAW.
In addition, no icons on the desktop are created for the Stanlone version!
I uninstalled and reinstalled several SCALER_EQ, nothing worked. I updated CUBASE 12 PRO to CUABSE PRO 13, nothing changed.

I have reported my problem to the technical services of PLUGIN BOUTIQUE via several messages.
I have had polite responses but no resolutions to date.
There is a problem, that’s for sure!

1 Like

Hi and welcome to the forum @GregTools We have @jchdejong who heads up our development team looking into this and not sure if we have a ticket of yours with PIB too but we are looking into this and see of we can sort something out. As mentioned it’s hard to diagnose something when we haven’t been able to replicate anything on our end and the amount of users having issues is less than 1%. Irrespective we are investigating best we can to see if there is a gremlin somewhere. Please hold tight.

Hello @GregTools, indeed we haven’t been able to reproduce this issue on our side, but we are looking into it! A quick question: does the standalone version of ScalerEQ open correctly? (Apart from not having an icon; that is unrelated). Or do you get a similar screen like @Navado? I suspect there is indeed some reason why the ‘OpenGL’ part of the ScalerEQ is not working on your machines. Is it perhaps possible to share with me the specs of both of your graphic’s cards? All the best, Jochem

1 Like

Hello @jchdejong
Thank you for your attention.

Before responding in more detail to your requests for information on my graphics card, could you tell me where the standalone version of SCALER_EQ was installed by default. I can not find it !?
What is the file name?
I obviously left all the boxes checked during installation and I left the default paths that the installer offers.

And I don’t seem to have the same reaction as @Navado.
For me, after installation, I restart my PC then I open CUBASE Pro v13 and I put SCALER_EQ in an audio channel strip and there CUBASE hangs. I no longer have access to any menu and am therefore forced to close CUBASE by the task manager.

For informations :
Unlike with SCALER_EQ, the installation with SCALER_2 went well.

Hi @GregTools that would be: C:\Program Files\Plugin Boutique\Scaler EQ\Scaler EQ.exe :slight_smile:

Hello @jchdejong
I run scaler.exe and it has been running for 7 minutes with no results.

I found a possible clue to the problem:
In Task Manager, the “User Account Control Virtualization” column is “Disabled”
Is this the cause of my problems!?
I don’t know how to activate this virtualization…
Do you have an idea to activate this virtualization…

Musically yours! :slight_smile:

Hi @GregTools

Thanks for testing :slight_smile: Does ‘Scaler EQ.exe’ not even open at all you mean, or do you see an empty screen?

I don’t know the answer to your question, but I will discuss the ‘virtualization’ setting with my team on Monday!

Many thanks,

Hello @jchdejong

I run scaler.exe and it runs without results. No special screens. Simply a “Processor” occupation without result.

Thank you for your attention,
Have a nice week end

Same thing here . The last response i got was i am the only one with the issue. So i left it alone

Scaler.exe is found … no scaler EQ.EXE.

Hello @jchdejong

I’ll come back to you to give you some information on my graphics card:

  • Card: @oem62.inf,%nvidia_dev.13c0%;NVIDIA GeForce GTX 980
  • Chipset:
  • RAM: 24.48 MB
  • Color depth: 32 bits
  • Font resolution: 96 pixels
  • Display size: 52.70 x 29.60 cm
  • Screen resolution: 1920 x 1080 pixels
  • Refresh frequency: 60 hertz
  • DAC (D/A converter):
  • Video BIOS - Date: 02/09/15
  • Video BIOS - Name:
  • Video BIOS - Version: Version
  • Version: 10.0.19041.3636 (WinBuild.160101.0800)

Out of more than 700 plugins installed in my studio configuration, this is the first time that a standalone version does not present a personalized icon on the “.exe” executable file and does not present an icon on the desktop either. .
For me there was a problem during installation.
I have uninstalled SCALER_EQ cleanly and several times (at least 5 times).
Always the same result. Either a component is missing from my PC computer and which one? (until now I’ve never had this kind of problem, for at least fifteen years without having had a message warning me of a problem)

…or maybe the install file is corrupt!?

good week,
Musically yours

Scaler EQ standalone works fine but does not work in ableton or studio one 5